# Logstash input Kafka error

**URL:** <https://discuss.elastic.co/t/logstash-input-kafka-error/291345>\
**Category:** Logstash\
**Created:** [December 9, 2021, 4:10pm UTC](https://discuss.elastic.co/t/logstash-input-kafka-error/291345 "2021-12-09T16:10:56Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Khaled\_Saidi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khaled_saidi/32/98636_2.png) [@Khaled\_Saidi](https://discuss.elastic.co/u/Khaled_Saidi)\
**Post date:** [December 9, 2021, 4:10pm UTC](https://discuss.elastic.co/t/logstash-input-kafka-error/291345/1 "2021-12-09T16:10:56Z")

</div>

Hi evrery one,  
i'm facing an issue while using kafka as my logstash input.  
when i started logstash i have this error :

`Unable to poll Kafka consumer {:kafka_error_message=>org.apache.kafka.common.KafkaException: Received exception when fetching the next record from type_topics-1. If needed, please seek past the record to continue consumption.`

My logstash conf is ok.  
No error when checking messages with kafka-console-consumer tool.  
Any help will be appreciate 🙂

Thanx

---

<div class="post-metadata">

**Author:** ![Khaled\_Saidi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/khaled_saidi/32/98636_2.png) [@Khaled\_Saidi](https://discuss.elastic.co/u/Khaled_Saidi)\
**Post date:** [December 13, 2021, 1:27pm UTC](https://discuss.elastic.co/t/logstash-input-kafka-error/291345/2 "2021-12-13T13:27:04Z")

</div>

[RESOLVED]

Uncomment` -Djava.io.tmpdir=$HOME` in the jvm.options configuration file fix my issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 10, 2022, 1:27pm UTC](https://discuss.elastic.co/t/logstash-input-kafka-error/291345/3 "2022-01-10T13:27:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
