# Logstash input sqs error

**URL:** https://discuss.elastic.co/t/logstash-input-sqs-error/134349
**Category:** Logstash
**Created:** [June 4, 2018, 2:33am UTC](https://discuss.elastic.co/t/logstash-input-sqs-error/134349 "2018-06-04T02:33:20Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![fafahei](https://avatars.discourse-cdn.com/v4/letter/f/977dab/32.png) [@fafahei](https://discuss.elastic.co/u/fafahei)
#### Post date: [June 4, 2018, 2:33am UTC](https://discuss.elastic.co/t/logstash-input-sqs-error/134349/1 "2018-06-04T02:33:20Z")

</div>

[ERROR] 2018-06-04 01:44:22.008 [[main]\<sqs] json - JSON parse error, original data now in message field {:error=\>#\<LogStash::Json::ParserError: Unexpected character (' ' (code 32)) in numeric value: expected digit (0-9) to follow minus sign, for valid numeric value

at [Source: (String)"- [AppWallAttackSysLogMessage devType="null" destinationPort="54001" request="GET /webfig/roteros.info HTTP/1.1  
Host: 94.188.210.31  
Connection: Keep-Alive  
Accept-Encoding: gzip, deflate  
Accept: _/_  
User-Agent: python-requests/2.18.4  
X-RDWR-IP: 188.92.74.189  
X-RDWR-PORT: 51224

" sourcePort="18762" role="public" aw....."}

[WARN] 2018-06-04 01:52:22.849 [[main]\<sqs] sqs - Aws::SQS::Errors::ServiceError ... retrying SQS request with exponential backoff {:queue=\>"Prd-a99bc332-9da8-4c95-befe-9c6689fa0867-APPWALL\_ATTACK", :sleep\_time=\>1, :error=\>#\<Aws::SQS::Errors::AccessDenied: Access to the resource [https://sqs.us-west-2.amazonaws.com/148229479130/Prd-a99bc332-9da8-4c95-befe-9c6689fa0867-APPWALL\_ATTACK](https://sqs.us-west-2.amazonaws.com/148229479130/Prd-a99bc332-9da8-4c95-befe-9c6689fa0867-APPWALL_ATTACK) is denied.\>}

As shown above, when I use logstash to process sqs, some error happened. Have someone encountered same problem or help solve this problem? Thanks.

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [June 4, 2018, 6:57am UTC](https://discuss.elastic.co/t/logstash-input-sqs-error/134349/2 "2018-06-04T06:57:47Z")

</div>

The default codec for the sqs input is "json" but you don't have JSON data. Change the codec to "plain" instead.

---

<div class="post-metadata">

### Author: ![nvjraja](https://avatars.discourse-cdn.com/v4/letter/n/f17d59/32.png) [@nvjraja](https://discuss.elastic.co/u/nvjraja)
#### Post date: [June 7, 2018, 7:42am UTC](https://discuss.elastic.co/t/logstash-input-sqs-error/134349/3 "2018-06-07T07:42:37Z")

</div>

Hi Rocky,

If you get solution, please post the input plugin configuration. I am also facing the same issue with parsing json logs.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2018, 7:43am UTC](https://discuss.elastic.co/t/logstash-input-sqs-error/134349/4 "2018-07-05T07:43:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
