# Logstash install error

**URL:** <https://discuss.elastic.co/t/logstash-install-error/138455>\
**Category:** Logstash\
**Created:** [July 3, 2018, 9:37pm UTC](https://discuss.elastic.co/t/logstash-install-error/138455 "2018-07-03T21:37:47Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![zekeriya\_tavlasoglu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zekeriya_tavlasoglu/32/42851_2.png) [@zekeriya\_tavlasoglu](https://discuss.elastic.co/u/zekeriya_tavlasoglu)\
**Post date:** [July 3, 2018, 9:37pm UTC](https://discuss.elastic.co/t/logstash-install-error/138455/1 "2018-07-03T21:37:48Z")

</div>

Hi,

when i try to install logstash on ubuntu, i am getting the error :

what is the problem?

can you help me.

thanks.  
Zekeriya.

sudo apt-get update && sudo apt-get install logstash  
Get:1 [http://security.ubuntu.com/ubuntu](http://security.ubuntu.com/ubuntu) bionic-security InRelease [83,2 kB]  
Hit:2 [http://tr.archive.ubuntu.com/ubuntu](http://tr.archive.ubuntu.com/ubuntu) bionic InRelease  
Get:3 [http://tr.archive.ubuntu.com/ubuntu](http://tr.archive.ubuntu.com/ubuntu) bionic-updates InRelease [88,7 kB]  
Get:4 [http://tr.archive.ubuntu.com/ubuntu](http://tr.archive.ubuntu.com/ubuntu) bionic-backports InRelease [74,6 kB]  
Ign:5 [https://artifacts.elastic.co/packages/6.x/apt](https://artifacts.elastic.co/packages/6.x/apt) stable InRelease  
Hit:6 [https://artifacts.elastic.co/packages/6.x/apt](https://artifacts.elastic.co/packages/6.x/apt) stable Release  
Fetched 247 kB in 1s (201 kB/s)  
Reading package lists... Done  
Reading package lists... Done  
Building dependency tree  
Reading state information... Done  
logstash is already the newest version (1:6.3.0-1).  
0 upgraded, 0 newly installed, 0 to remove and 188 not upgraded.  
1 not fully installed or removed.  
After this operation, 0 B of additional disk space will be used.  
Do you want to continue? [Y/n] y  
Setting up logstash (1:6.3.0-1) ...  
Using provided startup.options file: /etc/logstash/startup.options  
Unrecognized VM option 'UseParNewGC'  
_ **Error: Could not create the Java Virtual Machine.** _  
_ **Error: A fatal exception has occurred. Program will exit.** _  
_ **chmod: cannot access '/etc/default/logstash': No such file or directory** _  
_**dpkg: error processing package logstash (--configure):**_  
installed logstash package post-installation script subprocess returned error exit status 1  
Errors were encountered while processing:  
logstash  
E: Sub-process /usr/bin/dpkg returned an error code (1)

---

<div class="post-metadata">

**Author:** ![hamish](https://avatars.discourse-cdn.com/v4/letter/h/a5b964/32.png) [@hamish](https://discuss.elastic.co/u/hamish)\
**Post date:** [July 4, 2018, 7:58am UTC](https://discuss.elastic.co/t/logstash-install-error/138455/2 "2018-07-04T07:58:44Z")

</div>

I had the same problem yesterday. On my RHEL-7 installs it came down to an older version of IBM java being installed (Not sure why, it's a test system so has all sorts of stuff on it). I grabbed the latest 1.8\_171 and installed that separately then set JAVA\_HOME to run it rather than the system default one.

---

<div class="post-metadata">

**Author:** ![Alper\_Mehmet\_Ozdemir](https://avatars.discourse-cdn.com/v4/letter/a/eb9ed0/32.png) [@Alper\_Mehmet\_Ozdemir](https://discuss.elastic.co/u/Alper_Mehmet_Ozdemir)\
**Post date:** [July 4, 2018, 8:18am UTC](https://discuss.elastic.co/t/logstash-install-error/138455/3 "2018-07-04T08:18:57Z")

</div>

Same here. But the issue was resolved when I explicitly downloaded java 8 instead of using

```
sudo apt-get install java-default
```

---

<div class="post-metadata">

**Author:** ![zekeriya\_tavlasoglu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zekeriya_tavlasoglu/32/42851_2.png) [@zekeriya\_tavlasoglu](https://discuss.elastic.co/u/zekeriya_tavlasoglu)\
**Post date:** [July 11, 2018, 3:17pm UTC](https://discuss.elastic.co/t/logstash-install-error/138455/4 "2018-07-11T15:17:22Z")

</div>

Thank you. i could install with java version 8.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 8, 2018, 3:17pm UTC](https://discuss.elastic.co/t/logstash-install-error/138455/5 "2018-08-08T15:17:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
