# Logstash installation error

**URL:** <https://discuss.elastic.co/t/logstash-installation-error/116367>\
**Category:** Logstash\
**Created:** [January 21, 2018, 3:43am UTC](https://discuss.elastic.co/t/logstash-installation-error/116367 "2018-01-21T03:43:00Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Joe3](https://avatars.discourse-cdn.com/v4/letter/j/c67d28/32.png) [@Joe3](https://discuss.elastic.co/u/Joe3)\
**Post date:** [January 21, 2018, 3:43am UTC](https://discuss.elastic.co/t/logstash-installation-error/116367/1 "2018-01-21T03:43:00Z")

</div>

This is frst time trying to install Logstash on linux/ubuntu. I keep running into an error that logstash can't start. I have no clue what I did wrong. So I would be grateful if anyone can point me what I can do correct this. Thank you

The following are the errors that logstash gives

ubuntu@ip-172-31-6-195:~$ cd logstash-6.1.2/  
ubuntu@ip-172-31-6-195:~/logstash-6.1.2$ bin/logstash -e 'input { stdin { } } filter {} output { stdout { codec =\> rubydebug }'  
Sending Logstash's logs to /home/ubuntu/logstash-6.1.2/logs which is now configured via log4j2.properties  
[2018-01-21T02:55:11,155][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"fb\_apache", :directory=\>"/home/ubuntu/logstash-6.1.2/modules/fb\_apache/configuration"}  
[2018-01-21T02:55:11,195][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"netflow", :directory=\>"/home/ubuntu/logstash-6.1.2/modules/netflow/configuration"}  
[2018-01-21T02:55:11,256][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<ArgumentError: Setting "" hasn't been registered\>, :backtrace=\>["/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:32:in `get_setting'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:65:in`set\_value'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:84:in `block in merge'", "org/jruby/RubyHash.java:1343:in`each'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:84:in `merge'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:133:in`validate\_all'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/runner.rb:259:in `execute'", "/home/ubuntu/logstash-6.1.2/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in`run'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/runner.rb:214:in `run'", "/home/ubuntu/logstash-6.1.2/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in`run'", "/home/ubuntu/logstash-6.1.2/lib/bootstrap/environment.rb:67:in `'"]}  
ubuntu@ip-172-31-6-195:~/logstash-6.1.2$

ubuntu@ip-172-31-6-195:~/logstash-6.1.2$ clear  
ubuntu@ip-172-31-6-195:~/logstash-6.1.2$ bin/logstash -e  
Sending Logstash's logs to /home/ubuntu/logstash-6.1.2/logs which is now configured via log4j2.properties  
[2018-01-21T02:56:14,552][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"fb\_apache", :directory=\>"/home/ubuntu/logstash-6.1.2/modules/fb\_apache/configuration"}  
[2018-01-21T02:56:14,565][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"netflow", :directory=\>"/home/ubuntu/logstash-6.1.2/modules/netflow/configuration"}  
[2018-01-21T02:56:14,618][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<ArgumentError: Setting "" hasn't been registered\>, :backtrace=\>["/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:32:in `get_setting'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:65:in`set\_value'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:84:in `block in merge'", "org/jruby/RubyHash.java:1343:in`each'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:84:in `merge'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:133:in`validate\_all'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/runner.rb:259:in `execute'", "/home/ubuntu/logstash-6.1.2/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in`run'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/runner.rb:214:in `run'", "/home/ubuntu/logstash-6.1.2/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in`run'", "/home/ubuntu/logstash-6.1.2/lib/bootstrap/environment.rb:67:in `'"]}  
ubuntu@ip-172-31-6-195:~/logstash-6.1.2$

---

<div class="post-metadata">

**Author:** ![Joe3](https://avatars.discourse-cdn.com/v4/letter/j/c67d28/32.png) [@Joe3](https://discuss.elastic.co/u/Joe3)\
**Post date:** [January 22, 2018, 6:25am UTC](https://discuss.elastic.co/t/logstash-installation-error/116367/2 "2018-01-22T06:25:11Z")

</div>

I fixed the problem. Embarrasingly, this problem went away after I downloaded logstash.zip and installed. However, logstash.tar.gz still gave me the problem shown above. So my recommendation is to use .zip file download on Ubuntu.

---

<div class="post-metadata">

**Author:** ![Mojster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mojster/32/21209_2.png) [@Mojster](https://discuss.elastic.co/u/Mojster)\
**Post date:** [January 22, 2018, 6:35am UTC](https://discuss.elastic.co/t/logstash-installation-error/116367/3 "2018-01-22T06:35:37Z")

</div>

An alternative is to use Debian package.

[https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html)

---

<div class="post-metadata">

**Author:** ![Joe3](https://avatars.discourse-cdn.com/v4/letter/j/c67d28/32.png) [@Joe3](https://discuss.elastic.co/u/Joe3)\
**Post date:** [January 22, 2018, 6:37am UTC](https://discuss.elastic.co/t/logstash-installation-error/116367/4 "2018-01-22T06:37:26Z")

</div>

Thank you, Mojster!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 19, 2018, 6:37am UTC](https://discuss.elastic.co/t/logstash-installation-error/116367/5 "2018-02-19T06:37:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
