# Logstash Installation

**URL:** <https://discuss.elastic.co/t/logstash-installation/44206>\
**Category:** Logstash\
**Created:** [March 11, 2016, 10:03pm UTC](https://discuss.elastic.co/t/logstash-installation/44206 "2016-03-11T22:03:23Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![piyush](https://avatars.discourse-cdn.com/v4/letter/p/ecb155/32.png) [@piyush](https://discuss.elastic.co/u/piyush)\
**Post date:** [March 11, 2016, 10:03pm UTC](https://discuss.elastic.co/t/logstash-installation/44206/1 "2016-03-11T22:03:24Z")

</div>

Hi Team,  
I successfully tested Beats (Filebeat,topbeat,packetbeat) =\> ElasticSearch now i am trying for Beats =\> Logstash =\> Elasticsearch.

But i am getting error at beat end, though all traffic is allowed. I found some reading about logstash-input-beats. Do i need to install plugins to make logstash working? i was expecting it should work the way it worked with elasticsearch.

dial tcp w.x.y.z:5044: getsockopt: connection refused

Beat configuration:  
hosts: ["logstash:5044"]

Logstash Configuration:

input {  
beats {  
port =\> 5044  
ssl =\> false  
}  
}  
output {  
elasticsearch {  
hosts =\> ["[http://a.b.c.d:9200](http://a.b.c.d:9200)"]  
sniffing =\> true  
manage\_template =\> false  
index =\> "%{[@metadata][beat]}-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
file {  
path =\> "/test/logstash/fileout.put"  
}  
}

Regards...

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 11, 2016, 11:16pm UTC](https://discuss.elastic.co/t/logstash-installation/44206/2 "2016-03-11T23:16:13Z")

</div>

Can you telnet from the beats host to the LS one on port 5044? If not then there may be a firewall or other networking things stopping you.

---

<div class="post-metadata">

**Author:** ![piyush](https://avatars.discourse-cdn.com/v4/letter/p/ecb155/32.png) [@piyush](https://discuss.elastic.co/u/piyush)\
**Post date:** [March 12, 2016, 1:06am UTC](https://discuss.elastic.co/t/logstash-installation/44206/3 "2016-03-12T01:06:25Z")

</div>

ports were listening.  
I was looking at beat servers but found an issue on logstash server. I configured output to elasticsearch and a file. The file location had permission issue so logstash was failing. It's resolved now.

Thanks & Regards...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:07am UTC](https://discuss.elastic.co/t/logstash-installation/44206/4 "2017-07-06T05:07:19Z")

</div>


