# Logstash is not able to connect to workplace search

**URL:** <https://discuss.elastic.co/t/logstash-is-not-able-to-connect-to-workplace-search/330585>\
**Category:** Logstash\
**Created:** [April 23, 2023, 5:27pm UTC](https://discuss.elastic.co/t/logstash-is-not-able-to-connect-to-workplace-search/330585 "2023-04-23T17:27:44Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Disha\_Bodade](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/disha_bodade/32/84522_2.png) [@Disha\_Bodade](https://discuss.elastic.co/u/Disha_Bodade)\
**Post date:** [April 23, 2023, 5:27pm UTC](https://discuss.elastic.co/t/logstash-is-not-able-to-connect-to-workplace-search/330585/1 "2023-04-23T17:27:44Z")

</div>

Hi Team,  
I have added workplace search as a output plugin.

```auto
output {
  elastic_workplace_search {
    source => "6555639ee4f75566c32f4298"
    access_token => "efzq36opkajivo13judz65n9"
    url => "https://153.1.16.10:3002"
  }
}

```

logstash shows error:

```auto
[ERROR] 2023-04-23 13:12:22.410 [[main]-pipeline-manager] javapipeline - Pipeline error {:pipeline_id=>"main", :exception=>#<LogStash::ConfigurationError: Failed to connect to Workplace Search. Error: 404. Please check if url 'https://153.1.16.10:3002' is correct and you've created a source with ID '6555639ee4f75566c32f4298'>,

```

But my wokplace search is installed and running fine on given server ip.

logstash version: 7.17.3  
ws version: 8.6.2

What could be the issue version or configuration?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 21, 2023, 5:28pm UTC](https://discuss.elastic.co/t/logstash-is-not-able-to-connect-to-workplace-search/330585/2 "2023-05-21T17:28:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
