# Logstash is not starting.. i have installed a new version of Logstash 7.16.1 , it crashes saying fatal error

**URL:** <https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026>\
**Category:** Logstash\
**Created:** [December 15, 2021, 5:31pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026 "2021-12-15T17:31:53Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![AKAM14](https://avatars.discourse-cdn.com/v4/letter/a/7bcc69/32.png) [@AKAM14](https://discuss.elastic.co/u/AKAM14)\
**Post date:** [December 15, 2021, 5:31pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026/1 "2021-12-15T17:31:53Z")

</div>

Logstash is not starting, I have installed Logstash 7.16.1, this is the error i am getting in logstash

[2021-12-15T17:28:43,113][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.  
[2021-12-15T17:28:43,238][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600, :ssl\_enabled=\>false}  
[2021-12-15T17:28:48,366][INFO][logstash.runner] Logstash shut down.  
[2021-12-15T17:28:48,381][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit  
org.jruby.exceptions.SystemExit: (SystemExit) exit  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.20.1.jar:?]  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.20.1.jar:?]

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [December 15, 2021, 5:37pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026/2 "2021-12-15T17:37:34Z")

</div>

> [@AKAM14](#):
>
> No configuration found in the configured sources

See [this](https://discuss.elastic.co/t/fatal-470-logstash-stopped-processing-because-of-an-error-systemexit-exit/273091/2) answer.

---

<div class="post-metadata">

**Author:** ![AKAM14](https://avatars.discourse-cdn.com/v4/letter/a/7bcc69/32.png) [@AKAM14](https://discuss.elastic.co/u/AKAM14)\
**Post date:** [December 15, 2021, 5:53pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026/3 "2021-12-15T17:53:58Z")

</div>

input { stdin { } }

output {

Elasticsearch { hosts =\> ["localhost:9200"] }  
stdout { codec =\> rubydebug }

}

I have saved this in a logstash conf file.. and running a command from Powershell bin/logstash -f logstash.conf

---

<div class="post-metadata">

**Author:** ![AKAM14](https://avatars.discourse-cdn.com/v4/letter/a/7bcc69/32.png) [@AKAM14](https://discuss.elastic.co/u/AKAM14)\
**Post date:** [December 16, 2021, 5:02am UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026/4 "2021-12-16T05:02:31Z")

</div>

I am running the command from the command line : i have given the full path of the file , even then it keeps saying config file not found ..

PS C:\ELK3\Newfolder\logstash-7.16.1\> bin/logstash -f C:\ELK3\Newfolder\logstash-7.16.1\logstash.conf  
"Using bundled JDK: ."  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
Sending Logstash logs to C:/ELK3/Newfolder/logstash-7.16.1/logs which is now configured via log4j2.properties  
[2021-12-16T04:56:51,648][INFO][logstash.runner] Log4j configuration path used is: C:\ELK3\Newfolder\logstash-7.16.1\config\log4j2.properties  
[2021-12-16T04:56:51,679][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.16.1", "jruby.version"=\>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.13+8 on 11.0.13+8 +indy +jit [mswin32-x86\_64]"}  
[2021-12-16T04:56:51,882][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2021-12-16T04:56:51,929][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=\>"C:/ELK3/Newfolder/logstash-7.16.1/logstash.conf"}  
[2021-12-16T04:56:51,944][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.  
Configuration OK  
[2021-12-16T04:56:51,944][INFO][logstash.runner] Using config.test\_and\_exit mode. Config Validation Result: OK. Exiting Logstash

---

<div class="post-metadata">

**Author:** ![yaauie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yaauie/32/23363_2.png) [@yaauie](https://discuss.elastic.co/u/yaauie)\
**Post date:** [December 16, 2021, 6:21am UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026/5 "2021-12-16T06:21:46Z")

</div>

> [@AKAM14](#):
>
> [logstash.config.source.local.configpathloader] No config files found in path {:path=\>"C:/ELK3/Newfolder/logstash-7.16.1/logstash.conf"}

The file at that path, if it exists, is not readable by the Logstash process. What are its permissions? How is Logstash being run?

---

<div class="post-metadata">

**Author:** ![AKAM14](https://avatars.discourse-cdn.com/v4/letter/a/7bcc69/32.png) [@AKAM14](https://discuss.elastic.co/u/AKAM14)\
**Post date:** [December 16, 2021, 6:34am UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026/6 "2021-12-16T06:34:34Z")

</div>

It is a Windows Machine and it is in the C drive and all permissions are there..  
I am running Logstash from the Powershell window

---

<div class="post-metadata">

**Author:** ![AKAM14](https://avatars.discourse-cdn.com/v4/letter/a/7bcc69/32.png) [@AKAM14](https://discuss.elastic.co/u/AKAM14)\
**Post date:** [December 17, 2021, 5:05am UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026/7 "2021-12-17T05:05:27Z")

</div>

i have given the file path in the logstash.yml file .. in the path config location...

can some one please tell me, where is it looking for the path...i m not understanding ... is there a document to refer for this

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 14, 2022, 5:06am UTC](https://discuss.elastic.co/t/logstash-is-not-starting-i-have-installed-a-new-version-of-logstash-7-16-1-it-crashes-saying-fatal-error/292026/8 "2022-01-14T05:06:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
