# Logstash is not starting with Error execute Action Create/Pipeline\_main

**URL:** <https://discuss.elastic.co/t/logstash-is-not-starting-with-error-execute-action-create-pipeline-main/168598>\
**Category:** Logstash\
**Created:** [February 15, 2019, 1:40pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-with-error-execute-action-create-pipeline-main/168598 "2019-02-15T13:40:47Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nils\_Kaper](https://avatars.discourse-cdn.com/v4/letter/n/7feea3/32.png) [@Nils\_Kaper](https://discuss.elastic.co/u/Nils_Kaper)\
**Post date:** [February 15, 2019, 1:40pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-with-error-execute-action-create-pipeline-main/168598/1 "2019-02-15T13:40:47Z")

</div>

Hey,

I am constantly trying to get logstash to run. But unfortunately it always shows the error message which is mentioned in the title.

Here is my logstash.conf:

input {  
beats {  
port =\> 5044  
}  
}

filter{  
date{  
match =\> ["logdate", "YYYY-MM-dd'T'HH:mm:ss'.'SSSSSSXXX"]  
target =\> "@timestamp"  
}  
}

output {  
elasticsearch {  
hosts =\> ["[http://localhost:9200](http://localhost:9200)"]  
index =\> "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"

}  
}

Thanks for your help!

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [February 15, 2019, 2:15pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-with-error-execute-action-create-pipeline-main/168598/2 "2019-02-15T14:15:36Z")

</div>

What is the complete error message?

---

<div class="post-metadata">

**Author:** ![Nils\_Kaper](https://avatars.discourse-cdn.com/v4/letter/n/7feea3/32.png) [@Nils\_Kaper](https://discuss.elastic.co/u/Nils_Kaper)\
**Post date:** [February 15, 2019, 2:57pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-with-error-execute-action-create-pipeline-main/168598/3 "2019-02-15T14:57:50Z")

</div>

Sais body is limited to 7000 characters, so I can't post the whole error. But basically it is a JavaLang IllegalArgumentException for LogStash::PipelineAction::Create/pipeline\_id:main : backtrace

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [February 15, 2019, 3:03pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-with-error-execute-action-create-pipeline-main/168598/4 "2019-02-15T15:03:49Z")

</div>

That's odd. I would expect that configuration to fail with "Illegal pattern component: XXX".

---

<div class="post-metadata">

**Author:** ![Nils\_Kaper](https://avatars.discourse-cdn.com/v4/letter/n/7feea3/32.png) [@Nils\_Kaper](https://discuss.elastic.co/u/Nils_Kaper)\
**Post date:** [February 15, 2019, 3:06pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-with-error-execute-action-create-pipeline-main/168598/5 "2019-02-15T15:06:05Z")

</div>

Fails with the same error if I put a "#" to comment it out

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 15, 2019, 3:06pm UTC](https://discuss.elastic.co/t/logstash-is-not-starting-with-error-execute-action-create-pipeline-main/168598/6 "2019-03-15T15:06:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
