# Logstash is not working when i am importing data

**URL:** <https://discuss.elastic.co/t/logstash-is-not-working-when-i-am-importing-data/213052>\
**Category:** Logstash\
**Created:** [December 26, 2019, 7:39am UTC](https://discuss.elastic.co/t/logstash-is-not-working-when-i-am-importing-data/213052 "2019-12-26T07:39:26Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Pramod\_Thakur](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pramod_thakur/32/48428_2.png) [@Pramod\_Thakur](https://discuss.elastic.co/u/Pramod_Thakur)\
**Post date:** [December 26, 2019, 7:39am UTC](https://discuss.elastic.co/t/logstash-is-not-working-when-i-am-importing-data/213052/1 "2019-12-26T07:39:26Z")

</div>

Hi Folks,

I am having the following setup.  
OS: Window 10 Enterprise 64 bit  
Elasticsearch, Logstash, Kibana version: 7.2.0

My elastic search and kibana is working fine. when I am trying to configure logstash its throwing error. I have added all ELK in the environment variable as well.  
input  
{  
stdin{}  
}  
output  
{  
elasticsearch {  
hosts =\> ["localhost:9200"]  
index =\> "testing-index"  
}

```
} 

```

When i am trying to run i get following error.  
C:\Pramod\rnd\ElasticSearch\logstash-7.2.0\>logstash -f kafka.conf  
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by org.jruby.runtime.encoding.EncodingService (file:/C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logstash-core/lib/jars/jruby-complete-9.2.7.0.jar) to field java.io.Console.cs  
WARNING: Please consider reporting this to the maintainers of org.jruby.runtime.encoding.EncodingService  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
Thread.exclusive is deprecated, use Thread::Mutex  
Sending Logstash logs to C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logs which is now configured via log4j2.properties  
[2019-12-26T12:51:27,108][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2019-12-26T12:51:27,123][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.2.0"}  
[2019-12-26T12:51:27,801][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of #, { at line 1, column 6 (byte 6) after input", :backtrace=\>["C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logstash-core/lib/logstash/compiler.rb:49:in `compile\_graph'", "C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2577:in `map'", "C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:151:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:47:in `initialize'", "C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logstash-core/lib/logstash/java_pipeline.rb:24:in `initialize'", "C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logstash-core/lib/logstash/pipeline\_action/create.rb:36:in `execute'", "C:/Pramod/rnd/ElasticSearch/logstash-7.2.0/logstash-core/lib/logstash/agent.rb:325:in `block in converge\_state'"]}  
[2019-12-26T12:51:28,159][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-12-26T12:51:33,028][INFO][logstash.runner] Logstash shut down.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/3/f/3f6522e3caae2b4779d571584f29f431b1593afd.png)

Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 23, 2020, 7:39am UTC](https://discuss.elastic.co/t/logstash-is-not-working-when-i-am-importing-data/213052/2 "2020-01-23T07:39:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
