# Logstash is trying to connect to xpack in logstash-oss 7.0.1 version

**URL:** <https://discuss.elastic.co/t/logstash-is-trying-to-connect-to-xpack-in-logstash-oss-7-0-1-version/186640>\
**Category:** Logstash\
**Created:** [June 20, 2019, 9:43am UTC](https://discuss.elastic.co/t/logstash-is-trying-to-connect-to-xpack-in-logstash-oss-7-0-1-version/186640 "2019-06-20T09:43:06Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![akshatsharma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshatsharma/32/84179_2.png) [@akshatsharma](https://discuss.elastic.co/u/akshatsharma)\
**Post date:** [June 20, 2019, 9:43am UTC](https://discuss.elastic.co/t/logstash-is-trying-to-connect-to-xpack-in-logstash-oss-7-0-1-version/186640/1 "2019-06-20T09:43:06Z")

</div>

Hi,

I am using elasticseach-oss 7.0.1 and logstash-oss 7.0.1 rpms in my docker image, both with searchguard. Elasticsearch is getting deployed and searchguard index is getting created. But when I deploy logstash, it keeps restarting and is going in error state with the following error:  
" LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError: Got response code '500' contacting Elasticsearch at URL '[https://elasticsearch.xxxxxx:9200/\_xpack](https://elasticsearch.xxxxxx:9200/_xpack)' "

my query is: why is it trying to connect to xpack when I am using oss version? How can I resolve this error?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 23, 2019, 11:27am UTC](https://discuss.elastic.co/t/logstash-is-trying-to-connect-to-xpack-in-logstash-oss-7-0-1-version/186640/2 "2019-06-23T11:27:52Z")

</div>

I found [this issue](https://github.com/elastic/logstash/issues/10783), which seems to indicate there may be something wrong with Logstash packaging. If this seems similar to your issue I would recommend you add details about your versions there as well.

---

<div class="post-metadata">

**Author:** ![akshatsharma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshatsharma/32/84179_2.png) [@akshatsharma](https://discuss.elastic.co/u/akshatsharma)\
**Post date:** [June 23, 2019, 12:38pm UTC](https://discuss.elastic.co/t/logstash-is-trying-to-connect-to-xpack-in-logstash-oss-7-0-1-version/186640/3 "2019-06-23T12:38:19Z")

</div>

@Christian_Dahlqvist Thank you for your response.  
I have added my details on the issue you have mentioned.

---

<div class="post-metadata">

**Author:** ![akshatsharma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshatsharma/32/84179_2.png) [@akshatsharma](https://discuss.elastic.co/u/akshatsharma)\
**Post date:** [June 27, 2019, 6:06am UTC](https://discuss.elastic.co/t/logstash-is-trying-to-connect-to-xpack-in-logstash-oss-7-0-1-version/186640/4 "2019-06-27T06:06:04Z")

</div>

This is a packaging issue that are fixed in further releases.

However, for 7.0.1, setting `ilm_enabled => false` in logstash configuration for elasticsearch output resolved this issue.

Refer [this](https://github.com/elastic/logstash/issues/10783) and [this](https://github.com/elastic/logstash/issues/10875) link for details.

-Akshat

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 25, 2019, 6:06am UTC](https://discuss.elastic.co/t/logstash-is-trying-to-connect-to-xpack-in-logstash-oss-7-0-1-version/186640/5 "2019-07-25T06:06:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
