# Logstash Issue : Failed to execute action

**URL:** https://discuss.elastic.co/t/logstash-issue-failed-to-execute-action/183439
**Category:** Logstash
**Created:** [May 30, 2019, 12:23am UTC](https://discuss.elastic.co/t/logstash-issue-failed-to-execute-action/183439 "2019-05-30T00:23:45Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Bhargav\_Ram\_Reddy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhargav_ram_reddy/32/47118_2.png) [@Bhargav\_Ram\_Reddy](https://discuss.elastic.co/u/Bhargav_Ram_Reddy)
#### Post date: [May 30, 2019, 12:23am UTC](https://discuss.elastic.co/t/logstash-issue-failed-to-execute-action/183439/1 "2019-05-30T00:23:45Z")

</div>

Hello, i have installed elasticsearch, created template (server-logs) and started the service on 9200  
Also, added below code in logstash config file but when i try to start logstash service it is throwing an error  
input {  
file {  
path =\> "/Users/bhargavramreddy/eclipse-workspace/Servers/maps/output.log"  
}  
}  
filter {

}

output {  
elasticsearch {  
hosts =\> ["localhost:9200"]  
index =\> “logs-%{+YYYY.MM.dd}”  
manage\_template =\> true  
template\_name =\> "server-logs"  
}  
stdout {}  
}

Can anyone help me with the solution? what's wrong here ?

ERROR LOG:  
Bhargavs-MacBook-Pro:logstash-7.1.1 bhargavramreddy$ bin/logstash -f config/logstash-sample.conf  
Sending Logstash logs to /Users/bhargavramreddy/Downloads/logstash-7.1.1/logs which is now configured via log4j2.properties  
[2019-05-29T17:12:04,977][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2019-05-29T17:12:04,998][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.1.1"}  
[2019-05-29T17:12:06,191][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of #, ", ', -, [, { at line 16, column 14 (byte 290) after output {\n elasticsearch {\n \thosts =\> ["localhost:9200"]\n \tindex =\> ", :backtrace=\>["/Users/bhargavramreddy/Downloads/logstash-7.1.1/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "/Users/bhargavramreddy/Downloads/logstash-7.1.1/logstash-core/lib/logstash/compiler.rb:49:in`compile\_graph'", "/Users/bhargavramreddy/Downloads/logstash-7.1.1/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2577:in`map'", "/Users/bhargavramreddy/Downloads/logstash-7.1.1/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:151:in`initialize'", "org/logstash/execution/JavaBasePipelineExt.java:47:in `initialize'", "/Users/bhargavramreddy/Downloads/logstash-7.1.1/logstash-core/lib/logstash/java_pipeline.rb:23:in`initialize'", "/Users/bhargavramreddy/Downloads/logstash-7.1.1/logstash-core/lib/logstash/pipeline\_action/create.rb:36:in `execute'", "/Users/bhargavramreddy/Downloads/logstash-7.1.1/logstash-core/lib/logstash/agent.rb:325:in`block in converge\_state'"]}  
[2019-05-29T17:12:06,502][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-05-29T17:12:11,556][INFO][logstash.runner] Logstash shut down.

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [May 30, 2019, 9:53am UTC](https://discuss.elastic.co/t/logstash-issue-failed-to-execute-action/183439/2 "2019-05-30T09:53:41Z")

</div>

Your configuration appears to have curly quotes rather than regular double quotes around the value of index in the elasticsearch output.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 27, 2019, 9:55am UTC](https://discuss.elastic.co/t/logstash-issue-failed-to-execute-action/183439/3 "2019-06-27T09:55:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
