# Logstash : Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release

**URL:** <https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060>\
**Category:** Logstash\
**Created:** [January 22, 2020, 12:54pm UTC](https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060 "2020-01-22T12:54:58Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ekta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ekta/32/55987_2.png) [@Ekta](https://discuss.elastic.co/u/Ekta)\
**Post date:** [January 22, 2020, 12:54pm UTC](https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060/1 "2020-01-22T12:54:58Z")

</div>

while shashing first log it show below warning:

/usr/share/logstash# bin/logstash -e 'input { stdin { } } output { stdout {} }'  
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely b e removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/ lib/jars/jruby-complete-9.2.7.0.jar) to field java.io.FileDescriptor.fd  
WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
Thread.exclusive is deprecated, use Thread::Mutex  
WARNING: Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console

Can anyone help into this?

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [January 22, 2020, 2:48pm UTC](https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060/2 "2020-01-22T14:48:00Z")

</div>

You could edit /etc/logstash/jvm.options to configure some GC options that your version of java likes.

---

<div class="post-metadata">

**Author:** ![Ekta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ekta/32/55987_2.png) [@Ekta](https://discuss.elastic.co/u/Ekta)\
**Post date:** [January 23, 2020, 12:59am UTC](https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060/3 "2020-01-23T00:59:25Z")

</div>

Hi Badger,

This is my jvm.options file can you help anything ?

## JVM configuration

# Xms represents the initial size of total heap space

# Xmx represents the maximum size of total heap space

-Xms1g  
-Xmx1g

################################################################

## Expert settings

################################################################

## 

## All settings below this section are considered

## expert settings. Don't tamper with them unless

## you understand what you are doing

## 

################################################################

## GC configuration

-XX:+UseConcMarkSweepGC  
-XX:CMSInitiatingOccupancyFraction=75  
-XX:+UseCMSInitiatingOccupancyOnly

## Locale

# Set the locale language

#-Duser.language=en

# Set the locale country

#-Duser.country=US

# Set the locale variant, if any

#-Duser.variant=

## basic

# set the I/O temp directory

#-Djava.io.tmpdir=$HOME

# set to headless, just in case

-Djava.awt.headless=true

# ensure UTF-8 encoding by default (e.g. filenames)

-Dfile.encoding=UTF-8

# use our provided JNA always versus the system one

#-Djna.nosys=true

# Turn on JRuby invokedynamic

-Djruby.compile.invokedynamic=true

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [January 23, 2020, 2:29am UTC](https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060/4 "2020-01-23T02:29:09Z")

</div>

> [@Ekta](#):
>
> -XX:+UseConcMarkSweepGC  
> -XX:CMSInitiatingOccupancyFraction=75  
> -XX:+UseCMSInitiatingOccupancyOnly

You could try commenting out these three. The second and third have no effect if the first is not enabled.

---

<div class="post-metadata">

**Author:** ![Ekta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ekta/32/55987_2.png) [@Ekta](https://discuss.elastic.co/u/Ekta)\
**Post date:** [January 23, 2020, 11:53am UTC](https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060/5 "2020-01-23T11:53:50Z")

</div>

Hi Badger

I comment on all these three variable  
then I sop the logstash service and again stat but it gives same

systemctl status logstash.service  
â logstash.service - logstash  
Loaded: loaded (/etc/systemd/system/logstash.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Wed 2020-01-22 21:34:18 EST; 9h ago  
Main PID: 25761 (code=exited, status=1/FAILURE)

Jan 22 21:34:18 xxxxxxx systemd[1]: logstash.service: Service hold-off time over, scheduling restart.  
Jan 22 21:34:18 xxxxxxx systemd[1]: logstash.service: Scheduled restart job, restart counter is at 5.  
Jan 22 21:34:18 xxxxxxx systemd[1]: Stopped logstash.  
Jan 22 21:34:18 xxxxxxx systemd[1]: logstash.service: Start request repeated too quickly.  
Jan 22 21:34:18 xxxxxxx systemd[1]: logstash.service: Failed with result 'exit-code'.  
Jan 22 21:34:18 xxxxxxx systemd[1]: Failed to start logstash.

---

<div class="post-metadata">

**Author:** ![Ekta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ekta/32/55987_2.png) [@Ekta](https://discuss.elastic.co/u/Ekta)\
**Post date:** [January 23, 2020, 12:51pm UTC](https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060/6 "2020-01-23T12:51:53Z")

</div>

Process: 25761 ExecStart=/usr/share/logstash/bin/logstash --path.settings /etc/logstash (code=exited, status=1/FAILURE)

Is this any error?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 20, 2020, 12:51pm UTC](https://discuss.elastic.co/t/logstash-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/216060/7 "2020-02-20T12:51:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
