# Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

**URL:** <https://discuss.elastic.co/t/logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/302879>\
**Category:** Logstash\
**Tags:** elastic-stack-monitoring, docker\
**Created:** [April 21, 2022, 7:38am UTC](https://discuss.elastic.co/t/logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/302879 "2022-04-21T07:38:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![sahir](https://avatars.discourse-cdn.com/v4/letter/s/7cd45c/32.png) [@sahir](https://discuss.elastic.co/u/sahir)\
**Post date:** [April 21, 2022, 7:38am UTC](https://discuss.elastic.co/t/logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/302879/1 "2022-04-21T07:38:46Z")

</div>

Hello team, I try to run the logstash.conf file im facing the error like

```auto
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.11.1.jar) to method sun.nio.ch.NativeThread.signal(long)
WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console
[WARN] 2022-04-21 07:28:45.842 [LogStash::Runner] multilocal - Ignoring the 'pipelines.yml' file because modules or command line options are specified
[FATAL] 2022-04-21 07:28:45.879 [LogStash::Runner] runner - Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must change the "path.data" setting.
[ERROR] 2022-04-21 07:28:45.882 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

```

This is a conf file

```
 elasticsearch {
    hosts => ["https://xxxxxxx:9200"]
    user => 'xxxxx'
    password => 'xxxxxxxx'
    index => "logstash-beta-%{+YYYY.MM.dd}"
    ilm_enabled => false
  }
}    

```

any one please give me solution for this.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 19, 2022, 7:39am UTC](https://discuss.elastic.co/t/logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/302879/2 "2022-05-19T07:39:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
