# Logstash - JDBC ERROR

**URL:** <https://discuss.elastic.co/t/logstash-jdbc-error/254160>\
**Category:** Logstash\
**Created:** [November 3, 2020, 1:11pm UTC](https://discuss.elastic.co/t/logstash-jdbc-error/254160 "2020-11-03T13:11:53Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![peledev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/peledev/32/78323_2.png) [@peledev](https://discuss.elastic.co/u/peledev)\
**Post date:** [November 3, 2020, 1:11pm UTC](https://discuss.elastic.co/t/logstash-jdbc-error/254160/1 "2020-11-03T13:11:53Z")

</div>

Hello ,  
Im using logstash in a linux server  
I have installed the latest update for logstash on my server  
And also jdbc installed  
Ever since the update im unable to run jdbc output  
I get an error in the log :

'`Preformatted text`[2020-10-29T15:38:13,853][ERROR][logstash.pipeline] Pipeline aborted due to error {:pipeline\_id=\>"main", :exception=\>java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection, :backtrace=\>["oracle.jdbc.driver.T4CConnection.logon(oracle/jdbc/driver/T4CConnection.java:489)", "oracle.jdbc.driver.PhysicalConnection.(oracle/jdbc/driver/PhysicalConnection.java:553)", "oracle.jdbc.driver.T4CConnection.(oracle/jdbc/driver/T4CConnection.java:254)", "oracle.jdbc.driver.T4CDriverExtension.getConnection(oracle/jdbc/driver/T4CDriverExtension.java:32)", "oracle.jdbc.driver.OracleDriver.connect(oracle/jdbc/driver/OracleDriver.java:528)", "com.zaxxer.hikari.util.DriverDataSource.getConnection(com/zaxxer/hikari/util/DriverDataSource.java:117)", "com.zaxxer.hikari.pool.PoolBase.newConnection(com/zaxxer/hikari/pool/PoolBase.java:375)", "com.zaxxer.hikari.pool.PoolBase.newPoolEntry(com/zaxxer/hikari/pool/PoolBase.java:204)", "com.zaxxer.hikari.pool.HikariPool.createPoolEntry(com/zaxxer/hikari/pool/HikariPool.java:445)", "com.zaxxer.hikari.pool.HikariPool.checkFailFast(com/zaxxer/hikari/pool/HikariPool.java:516)", "com.zaxxer.hikari.pool.HikariPool.(com/zaxxer/hikari/pool/HikariPool.java:116)", "com.zaxxer.hikari.HikariDataSource.getConnection(com/zaxxer/hikari/HikariDataSource.java:97)", "java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:498)", "org.jruby.javasupport.JavaMethod.invokeDirectWithExceptionHandling(org/jruby/javasupport/JavaMethod.java:440)", "org.jruby.javasupport.JavaMethod.invokeDirect(org/jruby/javasupport/JavaMethod.java:304)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_output\_minus\_jdbc\_minus\_5\_dot\_4\_dot\_0.lib.logstash.outputs.jdbc.setup\_and\_test\_pool!(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-jdbc-5.4.0/lib/logstash/outputs/jdbc.rb:169)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_output\_minus\_jdbc\_minus\_5\_dot\_4\_dot\_0.lib.logstash.outputs.jdbc.RUBY$method$setup\_and\_test\_pool!0 **VARARGS** (usr/share/logstash/vendor/bundle/jruby/$2\_dot\_5\_dot\_0/gems/logstash\_minus\_output\_minus\_jdbc\_minus\_5\_dot\_4\_dot\_0/lib/logstash/outputs//usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-jdbc-5.4.0/lib/logstash/outputs/jdbc.rb)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_output\_minus\_jdbc\_minus\_5\_dot\_4\_dot\_0.lib.logstash.outputs.jdbc.register(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-jdbc-5.4.0/lib/logstash/outputs/jdbc.rb:127)", "org.jruby.RubyClass.finvoke(org/jruby/RubyClass.java:548)", "org.jruby.RubyBasicObject.callMethod(org/jruby/RubyBasicObject.java:354)", "org.logstash.config.ir.compiler.OutputStrategyExt$SimpleAbstractOutputStrategyExt.reg(org/logstash/config/ir/compiler/OutputStrategyExt.java:246)", "org.logstash.config.ir.compiler.OutputStrategyExt$AbstractOutputStrategyExt.register(org/logstash/config/ir/compiler/OutputStrategyExt.java:106)", "org.logstash.config.ir.compiler.OutputDelegatorExt.doRegister(org/logstash/config/ir/compiler/OutputDelegatorExt.java:91)", "org.logstash.config.ir.compiler.AbstractOutputDelegatorExt.register(org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:48)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.register\_plugin(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:259)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.register\_plugins(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:270)", "org.jruby.RubyArray.each(org/jruby/RubyArray.java:1792)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.register\_plugins(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:270)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.RUBY$method$register\_plugins$0$ **VARARGS** (usr/share/logstash/logstash\_minus\_core/lib/logstash//usr/share/logstash/logstash-core/lib/logstash/pipeline.rb)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.maybe\_setup\_out\_plugins(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:611)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.RUBY$method$maybe\_setup\_out\_plugins$0$ **VARARGS** (usr/share/logstash/logstash\_minus\_core/lib/logstash//usr/share/logstash/logstash-core/lib/logstash/pipeline.rb)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.start\_workers(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:280)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.RUBY$method$start\_workers$0$ **VARARGS** (usr/share/logstash/logstash\_minus\_core/lib/logstash//usr/share/logstash/logstash-core/lib/logstash/pipeline.rb)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.run(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:217)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.RUBY$method$run$0$ **VARARGS** (usr/share/logstash/logstash\_minus\_core/lib/logstash//usr/share/logstash/logstash-core/lib/logstash/pipeline.rb)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline.start(/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:176)", "org.jruby.RubyProc.call(org/jruby/RubyProc.java:295)", "org.jruby.RubyProc.call(org/jruby/RubyProc.java:274)", "org.jruby.RubyProc.call(org/jruby/RubyProc.java:270)", "java.lang.Thread.run(java/lang/Thread.java:748)"], :thread=\>"#\<Thread:0x17a158b0 run\>"}  
[2020-10-29T15:38:13,856][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Reload, action\_result: false", :backtrace=\>nil}'

I tried looking online with no success to get an answer

---

<div class="post-metadata">

**Author:** ![Wolfram\_Haussig](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wolfram_haussig/32/70528_2.png) [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)\
**Post date:** [November 3, 2020, 1:43pm UTC](https://discuss.elastic.co/t/logstash-jdbc-error/254160/2 "2020-11-03T13:43:18Z")

</div>

Hi,

This does not seem like a Logstash error:

> [@peledev](#):
>
> java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection

Have you tried reaching the database from the Logstash server(e.g. using sqlplus)?

Best regards  
Wolfram

---

<div class="post-metadata">

**Author:** ![peledev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/peledev/32/78323_2.png) [@peledev](https://discuss.elastic.co/u/peledev)\
**Post date:** [November 4, 2020, 10:46am UTC](https://discuss.elastic.co/t/logstash-jdbc-error/254160/3 "2020-11-04T10:46:40Z")

</div>

removed and reinstalled  
now i get a diffrent error

A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::Beats port=\>5044, id=\>"9ce1bad252c53356d0d99a7635ed92df417b043ffe3448a98aaeb7702d68eb4f", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_02b2fc69-3590-433f-af0e-e58f234a3662", enable\_metric=\>true, charset=\>"UTF-8"\>, host=\>"0.0.0.0", ssl=\>false, add\_hostname=\>true, ssl\_verify\_mode=\>"none", ssl\_peer\_metadata=\>false, include\_codec\_tag=\>true, ssl\_handshake\_timeout=\>10000, tls\_min\_version=\>1, tls\_max\_version=\>1.2, cipher\_suites=\>["TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_GCM\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_GCM\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_RSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_128\_CBC\_SHA256", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA256"], client\_inactivity\_timeout=\>60, executor\_threads=\>2\>  
Error: Address already in use  
Exception: Java::JavaNet::BindException  
Stack: sun.nio.ch.Net.bind0(Native Method)  
sun.nio.ch.Net.bind(sun/nio/ch/Net.java:433)  
sun.nio.ch.Net.bind(sun/nio/ch/Net.java:425)  
sun.nio.ch.ServerSocketChannelImpl.bind(sun/nio/ch/ServerSocketChannelImpl.java:223)  
io.netty.channel.socket.nio.NioServerSocketChannel.doBind(io/netty/channel/socket/nio/NioServerSocketChannel.java:130)  
io.netty.channel.AbstractChannel$AbstractUnsafe.bind(io/netty/channel/AbstractChannel.java:558)  
io.netty.channel.DefaultChannelPipeline$HeadContext.bind(io/netty/channel/DefaultChannelPipeline.java:1358)  
io.netty.channel.AbstractChannelHandlerContext.invokeBind(io/netty/channel/AbstractChannelHandlerContext.java:501)  
io.netty.channel.AbstractChannelHandlerContext.bind(io/netty/channel/AbstractChannelHandlerContext.java:486)  
io.netty.channel.DefaultChannelPipeline.bind(io/netty/channel/DefaultChannelPipeline.java:1019)  
io.netty.channel.AbstractChannel.bind(io/netty/channel/AbstractChannel.java:254)  
io.netty.bootstrap.AbstractBootstrap$2.run(io/netty/bootstrap/AbstractBootstrap.java:366)  
io.netty.util.concurrent.AbstractEventExecutor.safeExecute(io/netty/util/concurrent/AbstractEventExecutor.java:163)  
io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(io/netty/util/concurrent/SingleThreadEventExecutor.java:404)  
io.netty.channel.nio.NioEventLoop.run(io/netty/channel/nio/NioEventLoop.java:462)  
io.netty.util.concurrent.SingleThreadEventExecutor$5.run(io/netty/util/concurrent/SingleThreadEventExecutor.java:897)  
io.netty.util.concurrent.FastThreadLocalRunnable.run(io/netty/util/concurrent/FastThreadLocalRunnable.java:30)  
java.lang.Thread.run(java/lang/Thread.java:748)

---

<div class="post-metadata">

**Author:** ![Wolfram\_Haussig](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wolfram_haussig/32/70528_2.png) [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)\
**Post date:** [November 4, 2020, 11:08am UTC](https://discuss.elastic.co/t/logstash-jdbc-error/254160/4 "2020-11-04T11:08:22Z")

</div>

> [@peledev](#):
>
> Error: Address already in use

This states theat the port is already in use. Do you have no other logstash instance or another pipeline with this port running?

---

<div class="post-metadata">

**Author:** ![peledev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/peledev/32/78323_2.png) [@peledev](https://discuss.elastic.co/u/peledev)\
**Post date:** [November 4, 2020, 12:07pm UTC](https://discuss.elastic.co/t/logstash-jdbc-error/254160/5 "2020-11-04T12:07:18Z")

</div>

> [@Wolfram\_Haussig](#):
>
> Do you have no other logstash instance or another pipeline with this port running?

no there are no other service running on the server  
i even rebooted it

only one:

[root@vrl-logapp2 ~]# sudo lsof -i:5044  
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME  
java 857 logstash 138u IPv6 41624 0t0 TCP \*:lxi-evntsvc (LISTEN)  
[root@vrl-logapp2 ~]#

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 2, 2020, 12:07pm UTC](https://discuss.elastic.co/t/logstash-jdbc-error/254160/6 "2020-12-02T12:07:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
