# Logstash jdbc for orcle seem to fail

**URL:** <https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031>\
**Category:** Logstash\
**Created:** [July 28, 2018, 1:05pm UTC](https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031 "2018-07-28T13:05:49Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![rcstart](https://avatars.discourse-cdn.com/v4/letter/r/7cd45c/32.png) [@rcstart](https://discuss.elastic.co/u/rcstart)\
**Post date:** [July 28, 2018, 1:05pm UTC](https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031/1 "2018-07-28T13:05:49Z")

</div>

i use logstash-2.2.0 to sychronize orcle and es,but it seem not to be done ,i have checked the log ,but i can not find an error on it! here is my configTIM%E5%9B%BE%E7%89%8720180728203609|690x108,i try to change the schedule,and it worked,but the next day ,it seem to be failed ,it did not work,please help me

---

<div class="post-metadata">

**Author:** ![rcstart](https://avatars.discourse-cdn.com/v4/letter/r/7cd45c/32.png) [@rcstart](https://discuss.elastic.co/u/rcstart)\
**Post date:** [July 28, 2018, 1:10pm UTC](https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031/3 "2018-07-28T13:10:02Z")

</div>

![TIM%E5%9B%BE%E7%89%8720180728210919](https://us1.discourse-cdn.com/elastic/original/3X/d/f/dfdc1c8dbbf601b6935936348cc53f3717ad3bfe.png)

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [July 28, 2018, 2:59pm UTC](https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031/4 "2018-07-28T14:59:27Z")

</div>

What does "fail" mean? The query succeeds but returns an incorrect number of records? It results in an error? Something else?

---

<div class="post-metadata">

**Author:** ![rcstart](https://avatars.discourse-cdn.com/v4/letter/r/7cd45c/32.png) [@rcstart](https://discuss.elastic.co/u/rcstart)\
**Post date:** [July 28, 2018, 3:49pm UTC](https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031/5 "2018-07-28T15:49:37Z")

</div>

i use kibana to check this data whether sucessfully into the es ,when i firstly to start the logstash ,i can get the data on kibana,but the next day (after the time what i assign schdule on the config ),i check again ,it is nothing ,but the orcle had the data ,i event check the es and logstash log but i can not find any error

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [July 28, 2018, 7:00pm UTC](https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031/6 "2018-07-28T19:00:12Z")

</div>

I suggest you temporarily replace your elasticsearch output with a `stdout { codec => rubydebug }` output to verify whether Logstash is fetching the expected rows. If that works you can shift your attention back to why it isn't getting into ES. Raising Logstash's log level might give additional clues into what's going on.

---

<div class="post-metadata">

**Author:** ![rcstart](https://avatars.discourse-cdn.com/v4/letter/r/7cd45c/32.png) [@rcstart](https://discuss.elastic.co/u/rcstart)\
**Post date:** [July 29, 2018, 3:16am UTC](https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031/7 "2018-07-29T03:16:29Z")

</div>

i have try to replace the output with the stdout ,it was fetching the expected rows,and the first day it can get into ES,but the next day it can not into the ES at the time i set.The data format is the same,so i don't known whether logstash was successfully get the data on the time .I want to make it work at 10:55 am every day,I wil try to raise the logstasth's log level and check it's state,Thank you for your suggestion.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 26, 2018, 3:27am UTC](https://discuss.elastic.co/t/logstash-jdbc-for-orcle-seem-to-fail/142031/8 "2018-08-26T03:27:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
