# Logstash Jdbc oracle issue

**URL:** <https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223>\
**Category:** Logstash\
**Created:** [May 1, 2019, 3:37pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223 "2019-05-01T15:37:49Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![hannkeat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hannkeat/32/45424_2.png) [@hannkeat](https://discuss.elastic.co/u/hannkeat)\
**Post date:** [May 1, 2019, 3:37pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/1 "2019-05-01T15:37:50Z")

</div>

Here is my input file

- logstash 6.7
- ojdbc8

input {  
jdbc {  
jdbc\_driver\_library =\> "/usr/lib/oracle/18.3/client64/lib/ojdbc8.jar"  
jdbc\_driver\_class =\> "Java::oracle.jdbc.driver.OracleDriver"  
jdbc\_connection\_string =\> "jdbc.oracle:thin:@local:1521/BOPPROD"  
jdbc\_user =\> "USR"  
jdbc\_password =\> "USR"  
statement =\> "select \* from testdata"  
}  
}

getting error  
[ERROR] 2019-05-01 23:19:22.574 [[main]\<jdbc] jdbc - Unable to connect to database. Tried 1 times {:error\_message=\>"LoadError: no such file to load -- sequel/adapters/jdbc.oracle"}

Please assist... thanks in advance.

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [May 1, 2019, 8:15pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/2 "2019-05-01T20:15:23Z")

</div>

did you try username/password - lower case?  
also you have to put schedule =\> "10 10 \* \* \*" (same as crontab entry)  
and I think you also need jdbc\_validate\_connection option.

I have pretty much same thing and it works

```
input {
    jdbc {
        jdbc_validate_connection => true
        jdbc_connection_string => "jdbc:oracle:thin:@ora03:1521/<db_name>"
        jdbc_user => "logstash"
        jdbc_password => "${LOGSTASH_PASSWORD}"
        jdbc_driver_library => "/usr/lib/oracle/12.2/client64/lib/ojdbc8.jar"
        jdbc_driver_class => "Java::oracle.jdbc.driver.OracleDriver"
        statement => "select * from employee"
        clean_run=>true
        schedule => "10 11 * * *"
       }
}

```

This runs daily at 11:10 am because I have clean\_run=\>true set.

---

<div class="post-metadata">

**Author:** ![hannkeat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hannkeat/32/45424_2.png) [@hannkeat](https://discuss.elastic.co/u/hannkeat)\
**Post date:** [May 1, 2019, 11:11pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/4 "2019-05-01T23:11:43Z")

</div>

tested.. but it same error still occur

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [May 2, 2019, 3:35pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/5 "2019-05-02T15:35:18Z")

</div>

what version is boppord database. may be jdbc version is not compatable with your database.  
try elk's jdbc version.  
download it and put it somewhere in your system then test

---

<div class="post-metadata">

**Author:** ![hannkeat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hannkeat/32/45424_2.png) [@hannkeat](https://discuss.elastic.co/u/hannkeat)\
**Post date:** [May 2, 2019, 4:20pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/6 "2019-05-02T16:20:48Z")

</div>

Oracle Version : Oracle Database 12c Enterprise Edition Release 12.2.0.1.0 - 64bit Production

Here is the error log:  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.18.0/lib/sequel/database/connecting.rb:88:in`load\_adapter'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.18.0/lib/sequel/database/connecting.rb:17:in `adapter_class' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.18.0/lib/sequel/database/connecting.rb:36:in`connect'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.18.0/lib/sequel/core.rb:121:in `connect' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc- **4.3.13** /lib/logstash/plugin_mixins/jdbc/jdbc.rb:115:in`block in jdbc\_connect'  
org/jruby/RubyKernel.java:1411:in `loop' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin_mixins/jdbc/jdbc.rb:112:in`jdbc\_connect'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:165:in `open_jdbc_connection' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin_mixins/jdbc/jdbc.rb:221:in`execute\_statement'  
/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/inputs/jdbc.rb:277:in `execute_query' /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/inputs/jdbc.rb:263:in`run'  
/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:426:in `inputworker' /usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:420:in`block in start\_input'  
[ERROR] 2019-05-03 00:10:24.164 [[main]\<jdbc] jdbc - Unable to connect to database. Tried 1 times {:error\_message=\>"LoadError: no such file to load -- sequel/adapters/jdbc.oracle"}

installed elk's jdbc version :  
 ![jdbc_plugin](https://us1.discourse-cdn.com/elastic/original/3X/2/3/23eda2fd329e875bbfa3d6bd2205b3a9a5cea2dc.png)

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [May 2, 2019, 4:37pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/7 "2019-05-02T16:37:01Z")

</div>

I am assuming you are able to connect on database locally using this user?

sqlplus USR/USR@BOPROD

---

<div class="post-metadata">

**Author:** ![mladen](https://avatars.discourse-cdn.com/v4/letter/m/e36b37/32.png) [@mladen](https://discuss.elastic.co/u/mladen)\
**Post date:** [May 2, 2019, 7:34pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/8 "2019-05-02T19:34:32Z")

</div>

Hello @hannkeat please try ojdbc6.jar driver. I am using it without problem to connect to Oracle 12c.

BR,  
Mladen

---

<div class="post-metadata">

**Author:** ![hannkeat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hannkeat/32/45424_2.png) [@hannkeat](https://discuss.elastic.co/u/hannkeat)\
**Post date:** [May 3, 2019, 3:20am UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/9 "2019-05-03T03:20:26Z")

</div>

remotely

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/e/6/e6edb34f94b4e26ec8e69a237e9ec1b4b63f7500.png)

i tried connect to 11g and 12c .. using sqlplus.. no issue.

But when execute logstash, same error thrown.

---

<div class="post-metadata">

**Author:** ![hannkeat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hannkeat/32/45424_2.png) [@hannkeat](https://discuss.elastic.co/u/hannkeat)\
**Post date:** [May 3, 2019, 3:56am UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/10 "2019-05-03T03:56:14Z")

</div>

Tried... same error 😪😰

---

<div class="post-metadata">

**Author:** ![mladen](https://avatars.discourse-cdn.com/v4/letter/m/e36b37/32.png) [@mladen](https://discuss.elastic.co/u/mladen)\
**Post date:** [May 3, 2019, 10:17am UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/11 "2019-05-03T10:17:34Z")

</div>

Hello @hannkeat, you have a typo in JDBC connection:

Your connection:

> jdbc\_connection\_string =\> "jdbc.oracle:thin:@local:1521/BOPPROD"

Instead of dot(.) you need to put colon(:):

> jdbc\_connection\_string =\> "jdbc:oracle:thin:@local:1521/BOPPROD"

---

<div class="post-metadata">

**Author:** ![hannkeat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hannkeat/32/45424_2.png) [@hannkeat](https://discuss.elastic.co/u/hannkeat)\
**Post date:** [May 3, 2019, 4:07pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/12 "2019-05-03T16:07:23Z")

</div>

ah ... my mistaken.. now it work ... thanks 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 31, 2019, 4:07pm UTC](https://discuss.elastic.co/t/logstash-jdbc-oracle-issue/179223/13 "2019-05-31T16:07:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
