# Logstash jms input server issue

**URL:** <https://discuss.elastic.co/t/logstash-jms-input-server-issue/150534>\
**Category:** Logstash\
**Created:** [October 1, 2018, 8:40am UTC](https://discuss.elastic.co/t/logstash-jms-input-server-issue/150534 "2018-10-01T08:40:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pgprb](https://avatars.discourse-cdn.com/v4/letter/p/6de8d8/32.png) [@pgprb](https://discuss.elastic.co/u/pgprb)\
**Post date:** [October 1, 2018, 8:40am UTC](https://discuss.elastic.co/t/logstash-jms-input-server-issue/150534/1 "2018-10-01T08:40:32Z")

</div>

Hi there,

I was trying to enable logstash to connect to a server (through environment variables, this is a Docker custom image) that has Tibco JMS message queues. However, I cannot use those environment variables in the .yml (EMS section) file (or I am not using them correctly in the file) and when I use the broker\_url config in logstash it looks like it is overridden by the .yml configuration.

So for instance, if I use ${JMS\_SERVER} in the broker\_url config, I get the JMS Consumer failed to connect to the server at localhost error. Which, I guess, is probably a default configuration in the server\_url yml file.

Any idea of how can I get this through?

Many thanks,  
Pedro

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 29, 2018, 8:40am UTC](https://discuss.elastic.co/t/logstash-jms-input-server-issue/150534/2 "2018-10-29T08:40:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
