# Logstash keystore create error

**URL:** <https://discuss.elastic.co/t/logstash-keystore-create-error/351854>\
**Category:** Logstash\
**Created:** [January 26, 2024, 7:03am UTC](https://discuss.elastic.co/t/logstash-keystore-create-error/351854 "2024-01-26T07:03:34Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jevonsnotes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jevonsnotes/32/130317_2.png) [@jevonsnotes](https://discuss.elastic.co/u/jevonsnotes)\
**Post date:** [January 26, 2024, 7:03am UTC](https://discuss.elastic.co/t/logstash-keystore-create-error/351854/1 "2024-01-26T07:03:34Z")

</div>

logstash version 7.11.1

when i try to create a keystore but got an error as \>uninitialized constant LogStash::Util::Password, how to resolve this?

```auto
[elk@centos70_112 logstash-7.11.1]$ ./bin/logstash-keystore --path.settings /home/gd4400/apphome/logstash-7.11.1/config create
Using bundled JDK: /home/gd4400/apphome/logstash-7.11.1/jdk
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
ERROR: Failed to load settings file from "path.settings". Aborting... path.setting=/home/gd4400/apphome/logstash-7.11.1/config, exception=NameError, message=>uninitialized constant LogStash::Util::Password

An Logstash keystore already exists. Overwrite ? [y/N] 

```

---

<div class="post-metadata">

**Author:** ![strawgate](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/strawgate/32/131008_2.png) [@strawgate](https://discuss.elastic.co/u/strawgate)\
**Post date:** [January 27, 2024, 3:07pm UTC](https://discuss.elastic.co/t/logstash-keystore-create-error/351854/2 "2024-01-27T15:07:16Z")

</div>

Based on the keystore documentation: [Secrets keystore for secure settings | Logstash Reference [8.12] | Elastic](https://www.elastic.co/guide/en/logstash/current/keystore.html)

My guess is that there is already a key store on disk, but the environment variable LOGSTASH\_KEYSTORE\_PASS isnt currently set to the password of that keystore.

So when you start the keystore app it can't unlock the keystore. The command is then offering to replace the key store for you which is the final prompt. If you are confident that there is nothing in that key store that is important and want to replace the key store you would just hit y and then hit enter.

---

<div class="post-metadata">

**Author:** ![jevonsnotes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jevonsnotes/32/130317_2.png) [@jevonsnotes](https://discuss.elastic.co/u/jevonsnotes)\
**Post date:** [February 4, 2024, 8:23am UTC](https://discuss.elastic.co/t/logstash-keystore-create-error/351854/3 "2024-02-04T08:23:32Z")

</div>

thks for help.I noticed that even if it continues, it can still run normally.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 3, 2024, 8:23am UTC](https://discuss.elastic.co/t/logstash-keystore-create-error/351854/4 "2024-03-03T08:23:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
