# Logstash-keystore create generates errors and directory "${sys:ls.log.format}"

**URL:** <https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366>\
**Category:** Logstash\
**Created:** [August 14, 2018, 3:53pm UTC](https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366 "2018-08-14T15:53:41Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jkfields](https://avatars.discourse-cdn.com/v4/letter/j/2acd7d/32.png) [@jkfields](https://discuss.elastic.co/u/jkfields)\
**Post date:** [August 14, 2018, 3:53pm UTC](https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366/1 "2018-08-14T15:53:42Z")

</div>

We have requirements from Security to secure our Elasticstack. On Logstash, I ran into errors creating the keystore. When I execute the following command(s) it results in the errors shown.

# /usr/share/logstash/bin/logstash-keystore --path.settings /etc/logstash create

2018-08-13 15:31:54, 583 main ERROR Unable to locate appender "${sys:ls.log.format}\_console" for logger config "root"  
2018-08-13 15:31:54, 584 main ERROR Unable to locate appender "${sys:ls.log.format}\_rolling" for logger config "root"  
2018-08-13 15:31:54, 584 main ERROR Unable to locate appender "${sys:ls.log.format}\_rolling\_slowlog" for logger config "slowlog"  
2018-08-13 15:31:54, 584 main ERROR Unable to locate appender "${sys:ls.log.format}\_console\_slowlog" for logger config "slowlog"

In /etc/logstash a directory with empty files are create in a directory named "${sys:ls.log.format}".

I installed logstash v6.3.2 via rpm on Red Hat Enterprise Linux 7.3.

Jeff

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [August 14, 2018, 5:02pm UTC](https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366/2 "2018-08-14T17:02:09Z")

</div>

> [@jkfields](#):
>
> 2018-08-13 15:31:54, 584 main ERROR Unable to locate appender "${sys:ls.log.format}\_rolling" for logger config "root"

Certainly in the past I have [seen that](https://discuss.elastic.co/t/logstash-is-creating-a-directory-literally-called-sys-ls-logs/100126) when running logstash from the path.settings directory. Does it happen if you cd to another directory?

---

<div class="post-metadata">

**Author:** ![jkfields](https://avatars.discourse-cdn.com/v4/letter/j/2acd7d/32.png) [@jkfields](https://discuss.elastic.co/u/jkfields)\
**Post date:** [August 14, 2018, 11:58pm UTC](https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366/3 "2018-08-14T23:58:41Z")

</div>

Thanks for the tip; running the command while in the /tmp worked.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 11, 2018, 11:58pm UTC](https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366/4 "2018-09-11T23:58:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
