# Logstash-keystore create generates errors and directory "${sys:ls.log.format}"

**URL:** <https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366>\
**Category:** Logstash\
**Created:** [August 14, 2018, 3:53pm UTC](https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366 "2018-08-14T15:53:41Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [August 14, 2018, 5:02pm UTC](https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366/2 "2018-08-14T17:02:09Z")

</div>

> [@jkfields](#):
>
> 2018-08-13 15:31:54, 584 main ERROR Unable to locate appender "${sys:ls.log.format}\_rolling" for logger config "root"

Certainly in the past I have [seen that](https://discuss.elastic.co/t/logstash-is-creating-a-directory-literally-called-sys-ls-logs/100126) when running logstash from the path.settings directory. Does it happen if you cd to another directory?

---

_[View the full topic](https://discuss.elastic.co/t/logstash-keystore-create-generates-errors-and-directory-sys-ls-log-format/144366)._
