# Logstash-keystore error

**URL:** <https://discuss.elastic.co/t/logstash-keystore-error/301216>\
**Category:** Logstash\
**Tags:** docker\
**Created:** [March 31, 2022, 2:46pm UTC](https://discuss.elastic.co/t/logstash-keystore-error/301216 "2022-03-31T14:46:56Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![jack3368](https://avatars.discourse-cdn.com/v4/letter/j/e9c0ed/32.png) [@jack3368](https://discuss.elastic.co/u/jack3368)\
**Post date:** [March 31, 2022, 2:46pm UTC](https://discuss.elastic.co/t/logstash-keystore-error/301216/1 "2022-03-31T14:46:57Z")

</div>

I am upgrading logstash v7.5.2 to v7.17.1. The step in docker file that using logstash-keystore to create keystore always return the following error message:

```auto
Using bundled JDK: /usr/share/logstash/jdk

OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.

ERROR: Failed to load settings file from "path.settings". Aborting... path.setting=/usr/share/logstash/config, exception=NameError, message=>uninitialized constant I18n

Created Logstash keystore at /usr/share/logstash/config/logstash.keystore

```

But it seems to be created and is working. Should I ignore this error message?

---

<div class="post-metadata">

**Author:** ![DonKool](https://avatars.discourse-cdn.com/v4/letter/d/a4c791/32.png) [@DonKool](https://discuss.elastic.co/u/DonKool)\
**Post date:** [April 1, 2022, 7:49pm UTC](https://discuss.elastic.co/t/logstash-keystore-error/301216/2 "2022-04-01T19:49:35Z")

</div>

I posted about the same problem in [Logstash keystore uninitialized constant I18n](https://discuss.elastic.co/t/logstash-keystore-uninitialized-constant-i18n/301270). Glad to see I'm not the only one with this problem.

The command will create the keystore file. My problem is that I'm using Docker and the error keeps the container from starting. Hopefully someone knows how to fix this.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 29, 2022, 7:49pm UTC](https://discuss.elastic.co/t/logstash-keystore-error/301216/3 "2022-04-29T19:49:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
