# Logstash keystore uninitialized constant I18n

**URL:** <https://discuss.elastic.co/t/logstash-keystore-uninitialized-constant-i18n/301270>\
**Category:** Logstash\
**Tags:** docker\
**Created:** [March 31, 2022, 10:08pm UTC](https://discuss.elastic.co/t/logstash-keystore-uninitialized-constant-i18n/301270 "2022-03-31T22:08:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![DonKool](https://avatars.discourse-cdn.com/v4/letter/d/a4c791/32.png) [@DonKool](https://discuss.elastic.co/u/DonKool)\
**Post date:** [March 31, 2022, 10:08pm UTC](https://discuss.elastic.co/t/logstash-keystore-uninitialized-constant-i18n/301270/1 "2022-03-31T22:08:31Z")

</div>

Running version 8.1.1 of ELK in Docker containers. Trying to secure the Logstash API on port 9600. This requires the creation of a keystore file. When trying to create a Logstash keystore file, get the following error. Have tried running this inside the Logstash container as both root and as the logstash user. Apparently the error about I18n is a Ruby error but I don't know what to change to fix it. Any help would be appreciated.

```auto
logstash@567e83bf6597:~$ logstash-keystore create
Using bundled JDK: /usr/share/logstash/jdk
ERROR: Failed to load settings file from "path.settings". Aborting... path.setting=/usr/share/logstash/config, exception=NameError, message=>uninitialized constant I18n
Sending Logstash logs to /usr/share/logstash/logs which is now configured via log4j2.properties

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 28, 2022, 10:08pm UTC](https://discuss.elastic.co/t/logstash-keystore-uninitialized-constant-i18n/301270/2 "2022-04-28T22:08:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
