# Logstash kibana

**URL:** <https://discuss.elastic.co/t/logstash-kibana/183319>\
**Category:** Logstash\
**Created:** [May 29, 2019, 11:33am UTC](https://discuss.elastic.co/t/logstash-kibana/183319 "2019-05-29T11:33:34Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 29, 2019, 11:33am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/1 "2019-05-29T11:33:34Z")

</div>

not able to load data from mysql to elasticsearch using logstash?

---

<div class="post-metadata">

**Author:** ![Askia\_Mohamed\_Kadri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/askia_mohamed_kadri/32/134665_2.png) [@Askia\_Mohamed\_Kadri](https://discuss.elastic.co/u/Askia_Mohamed_Kadri)\
**Post date:** [May 29, 2019, 11:36am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/2 "2019-05-29T11:36:52Z")

</div>

Can you please formulate you request more precisely

---

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 29, 2019, 11:37am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/3 "2019-05-29T11:37:59Z")

</div>

i am getting this error

C:\ELK\logstash-7.0.1\bin\>logstash -f C:\ELK\logstash-7.0.1\config\lat\_long\_geopoint.conf  
Sending Logstash logs to C:/ELK/logstash-7.0.1/logs which is now configured via log4j2.properties  
[2019-05-29T16:48:15,407][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2019-05-29T16:48:15,422][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.0.1"}  
[2019-05-29T16:48:19,544][ERROR][logstash.outputs.elasticsearch] Unknown setting '"document\_type"' for elasticsearch  
[2019-05-29T16:48:19,545][ERROR][logstash.outputs.elasticsearch] Unknown setting '"hosts"' for elasticsearch  
[2019-05-29T16:48:19,546][ERROR][logstash.outputs.elasticsearch] Unknown setting '"index"' for elasticsearch  
[2019-05-29T16:48:19,553][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Something is wrong with your configuration.", :backtrace=\>["C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/config/mixin.rb:86:in `config_init'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/outputs/base.rb:60:in`initialize'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:232:in `initialize'", "org/logstash/config/ir/compiler/OutputDelegatorExt.java:48:in`initialize'", "org/logstash/config/ir/compiler/OutputDelegatorExt.java:30:in `initialize'", "org/logstash/plugins/PluginFactoryExt.java:239:in`plugin'", "org/logstash/plugins/PluginFactoryExt.java:137:in `buildOutput'", "org/logstash/execution/JavaBasePipelineExt.java:50:in`initialize'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/java\_pipeline.rb:23:in `initialize'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/pipeline_action/create.rb:36:in`execute'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/agent.rb:325:in `block in converge\_state'"]}  
[2019-05-29T16:48:19,780][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-05-29T16:48:24,661][INFO][logstash.runner] Logstash shut down.

---

<div class="post-metadata">

**Author:** ![Askia\_Mohamed\_Kadri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/askia_mohamed_kadri/32/134665_2.png) [@Askia\_Mohamed\_Kadri](https://discuss.elastic.co/u/Askia_Mohamed_Kadri)\
**Post date:** [May 29, 2019, 11:40am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/4 "2019-05-29T11:40:55Z")

</div>

You have some parameters in your Logstash configuration that are not good. Can you please pot your Logstash config file?

---

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 29, 2019, 11:42am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/5 "2019-05-29T11:42:10Z")

</div>

this is my .conf file

input {  
jdbc {  
jdbc\_connection\_string =\> "jdbc:mysql://localhost:3306/test"  
# The user we wish to execute our statement as  
jdbc\_user =\> "root"  
jdbc\_password =\> "XXXXXXXXX"  
# The path to our downloaded jdbc driver  
jdbc\_driver\_library =\> "C:/ELK/logstash-7.0.1/bin/mysql-connector-java-8.0.16.jar"  
jdbc\_driver\_class =\> "com.mysql.jdbc.Driver"  
# our query  
statement =\> "SELECT \* FROM locn"  
}  
}  
output {  
stdout { codec =\> json\_lines }  
elasticsearch {  
"hosts" =\> "localhost:9200"  
"index" =\> "locn"  
"document\_type" =\> "data"  
}  
}

---

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 29, 2019, 11:51am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/6 "2019-05-29T11:51:33Z")

</div>

i am able to load data into elasticsearch using hive.  
i want to plot route using latitude and longitude data which are in different column of my .csv file and stored in hive.  
But i am not able to convert that latitude and longitude into Geopoint

---

<div class="post-metadata">

**Author:** ![Askia\_Mohamed\_Kadri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/askia_mohamed_kadri/32/134665_2.png) [@Askia\_Mohamed\_Kadri](https://discuss.elastic.co/u/Askia_Mohamed_Kadri)\
**Post date:** [May 29, 2019, 11:51am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/7 "2019-05-29T11:51:47Z")

</div>

You don't have to put **"** for hosts, index and document\_type.  
Try this instead:  
**elasticsearch {  
hosts =\> "localhost:9200"  
index =\> "locn"  
document\_type =\> "data"  
}**

They are keys, not strings

---

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 29, 2019, 11:54am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/8 "2019-05-29T11:54:29Z")

</div>

Now i got error like this

Sending Logstash logs to C:/ELK/logstash-7.0.1/logs which is now configured via log4j2.properties  
[2019-05-29T17:23:30,267][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2019-05-29T17:23:30,284][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.0.1"}  
[2019-05-29T17:23:31,185][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of #, =\> at line 17, column 17 (byte 532) after output {\r\n stdout { codec =\> json\_lines }\r\n elasticsearch {\r\n elasticsearch ", :backtrace=\>["C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/compiler.rb:49:in`compile\_graph'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2577:in`map'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:151:in`initialize'", "org/logstash/execution/JavaBasePipelineExt.java:47:in `initialize'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/java_pipeline.rb:23:in`initialize'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/pipeline\_action/create.rb:36:in `execute'", "C:/ELK/logstash-7.0.1/logstash-core/lib/logstash/agent.rb:325:in`block in converge\_state'"]}  
[2019-05-29T17:23:31,467][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-05-29T17:23:36,335][INFO][logstash.runner] Logstash shut down.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [May 29, 2019, 11:59am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/9 "2019-05-29T11:59:48Z")

</div>

> [@krishnakekan](#):
>
> Expected one of #, =\> at line 17, column 17 (byte 532) after output {\r\n stdout { codec =\> json\_lines }\r\n elasticsearch {\r\n elasticsearch ",

Now it appears you have

```
output {
    stdout { codec => json_lines }
    elasticsearch {
        elasticsearch
            [...]

```

you should have

```
output {
    stdout { codec => json_lines }
    elasticsearch {
        hosts => "localhost:9200"
        index => "locn"
        document_type => "data"
    }
}

```

---

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 29, 2019, 12:16pm UTC](https://discuss.elastic.co/t/logstash-kibana/183319/10 "2019-05-29T12:16:41Z")

</div>

previous errors are solved.  
can you tell me how to convert latitude & longitude into geopoint.  
i have created table into hive where i have two columns as latitude and longitude

---

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 29, 2019, 12:48pm UTC](https://discuss.elastic.co/t/logstash-kibana/183319/11 "2019-05-29T12:48:13Z")

</div>

i am getting this error

[2019-05-29T18:12:02,888][WARN][logstash.outputs.elasticsearch] Could not index event to Elasticsearch. {:status=\>400, :action=\>["index", {:\_id=\>nil, :\_index=\>"locn", :\_type=\>"data", :routing=\>nil}, #LogStash::Event:0x36630b61], :response=\>{"index"=\>{"\_index"=\>"locn", "\_type"=\>"data", "\_id"=\>"LAycA2sBdDeincm\_jMXo", "status"=\>400, "error"=\>{"type"=\>"illegal\_argument\_exception", "reason"=\>"Rejecting mapping update to [locn] as the final mapping would have more than 1 type: [\_doc, data]"}}}}  
[2019-05-29T18:12:03,813][INFO][logstash.runner] Logstash shut down.

---

<div class="post-metadata">

**Author:** ![Askia\_Mohamed\_Kadri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/askia_mohamed_kadri/32/134665_2.png) [@Askia\_Mohamed\_Kadri](https://discuss.elastic.co/u/Askia_Mohamed_Kadri)\
**Post date:** [May 29, 2019, 1:56pm UTC](https://discuss.elastic.co/t/logstash-kibana/183319/12 "2019-05-29T13:56:12Z")

</div>

Seems like you are trying to push in your index (locn) that has mapping type \_doc, new that with mapping type data.

---

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 30, 2019, 4:15am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/13 "2019-05-30T04:15:48Z")

</div>

locn is index that i have created in kibana

---

<div class="post-metadata">

**Author:** ![krishnakekan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krishnakekan/32/47067_2.png) [@krishnakekan](https://discuss.elastic.co/u/krishnakekan)\
**Post date:** [May 30, 2019, 5:10am UTC](https://discuss.elastic.co/t/logstash-kibana/183319/14 "2019-05-30T05:10:52Z")

</div>

i have removed document type and now its mapped with kibana  
thanks buddy

---

<div class="post-metadata">

**Author:** ![Askia\_Mohamed\_Kadri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/askia_mohamed_kadri/32/134665_2.png) [@Askia\_Mohamed\_Kadri](https://discuss.elastic.co/u/Askia_Mohamed_Kadri)\
**Post date:** [June 3, 2019, 12:32pm UTC](https://discuss.elastic.co/t/logstash-kibana/183319/15 "2019-06-03T12:32:11Z")

</div>

Glad it helped you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 1, 2019, 12:32pm UTC](https://discuss.elastic.co/t/logstash-kibana/183319/16 "2019-07-01T12:32:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
