# Logstash Load Error - Java

**URL:** <https://discuss.elastic.co/t/logstash-load-error-java/104688>\
**Category:** Logstash\
**Created:** [October 20, 2017, 11:12am UTC](https://discuss.elastic.co/t/logstash-load-error-java/104688 "2017-10-20T11:12:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![perkstvr](https://avatars.discourse-cdn.com/v4/letter/p/91b2a8/32.png) [@perkstvr](https://discuss.elastic.co/u/perkstvr)\
**Post date:** [October 20, 2017, 11:12am UTC](https://discuss.elastic.co/t/logstash-load-error-java/104688/1 "2017-10-20T11:12:55Z")

</div>

Can anyone help. I'm running elastic search 5.6.2 and log stash 5.6.3 (and tried 6.0.0) but I'm getting an error when trying to run log stash.

Java HotSpot(TM) 64-Bit Server VM warning: Option UseParNewGC was deprecated in version 9.0 and will likely be removed in a future release.  
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by org.jruby.util.io.FilenoUtil to method sun.nio.ch.SelChImpl.getFD()  
WARNING: Please consider reporting this to the maintainers of org.jruby.util.io.FilenoUtil  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
LoadError: load error: jopenssl/load -- java.lang.StringIndexOutOfBoundsException: begin 0, end 3, length 1  
require at org/jruby/RubyKernel.java:955

 at /Users/perkinsl/logstash-6.0.0-rc1/vendor/jruby/lib/ruby/stdlib/openssl.rb:1 require at org/jruby/RubyKernel.java:955 at /Users/perkinsl/logstash-6.0.0-rc1/logstash-core/lib/logstash/patches/stronger\_openssl\_defaults.rb:1 require at org/jruby/RubyKernel.java:955 at /Users/perkinsl/logstash-6.0.0-rc1/logstash-core/lib/logstash/patches/stronger\_openssl\_defaults.rb:2 require at org/jruby/RubyKernel.java:955 at /Users/perkinsl/logstash-6.0.0-rc1/logstash-core/lib/logstash/patches.rb:1 require at org/jruby/RubyKernel.java:955 at /Users/perkinsl/logstash-6.0.0-rc1/logstash-core/lib/logstash/patches.rb:5 require at org/jruby/RubyKernel.java:955 at /Users/perkinsl/logstash-6.0.0-rc1/lib/bootstrap/environment.rb:70

---

<div class="post-metadata">

**Author:** ![perkstvr](https://avatars.discourse-cdn.com/v4/letter/p/91b2a8/32.png) [@perkstvr](https://discuss.elastic.co/u/perkstvr)\
**Post date:** [October 26, 2017, 1:57pm UTC](https://discuss.elastic.co/t/logstash-load-error-java/104688/2 "2017-10-26T13:57:44Z")

</div>

A complete uninstall/re-install of the JDK and setting Java\_Home seems to have resolved the problem.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 23, 2017, 1:57pm UTC](https://discuss.elastic.co/t/logstash-load-error-java/104688/3 "2017-11-23T13:57:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
