# Logstash - Load error

**URL:** <https://discuss.elastic.co/t/logstash-load-error/217654>\
**Category:** Logstash\
**Created:** [February 3, 2020, 3:42pm UTC](https://discuss.elastic.co/t/logstash-load-error/217654 "2020-02-03T15:42:59Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jaugsuto](https://avatars.discourse-cdn.com/v4/letter/j/ebca7d/32.png) [@jaugsuto](https://discuss.elastic.co/u/jaugsuto)\
**Post date:** [February 3, 2020, 3:43pm UTC](https://discuss.elastic.co/t/logstash-load-error/217654/1 "2020-02-03T15:43:00Z")

</div>

Hi

I have installed already several times the elastic stack all via the tar.gz files.  
This error that im having now is only regarding Logstash.

When I start Logstash is returns this error

[ERROR] 2020-02-03 15:10:23.030 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) load error: rubygems/security -- java.lang.ExceptionInInitializerError: null

Then is stops. I tried to change the log files level but this message was still the only one.

The only environment change for this installation is the OS. On CentOS 7 all deployments were a success. On this server with RED HAT:  
Icon name: computer-vm  
Chassis: vm  
Virtualization: kvm  
Operating System: Red Hat Enterprise Linux  
CPE OS Name: cpe:/o:redhat:enterprise\_linux:7.7:GA:server  
Kernel: Linux 3.10.0-327.el7.x86\_64  
Architecture: x86-6

Can someone help?

Thanks in advance

---

<div class="post-metadata">

**Author:** ![kares](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kares/32/70705_2.png) [@kares](https://discuss.elastic.co/u/kares)\
**Post date:** [February 11, 2020, 3:04pm UTC](https://discuss.elastic.co/t/logstash-load-error/217654/2 "2020-02-11T15:04:33Z")

</div>

Hey, did you generated or are you using a LS keystore?

You could try enabling logging for the underlying JRuby runtime.  
There's likely going to be a lot of logs on stderr but we'll have a trace at least for the "load error" :

`LS_JAVA_OPTS="-Djruby.log.exceptions -Djruby.log.backtraces" bin/logstash`

---

<div class="post-metadata">

**Author:** ![jaugsuto](https://avatars.discourse-cdn.com/v4/letter/j/ebca7d/32.png) [@jaugsuto](https://discuss.elastic.co/u/jaugsuto)\
**Post date:** [February 11, 2020, 3:25pm UTC](https://discuss.elastic.co/t/logstash-load-error/217654/3 "2020-02-11T15:25:54Z")

</div>

Hi,

Forgot to update this issue...  
The issue was the java version. Well the java version was correct but don't know why it was installed an oracle java 1.8.. Logstash was not returning error when we are running a java 1.6 for example. I discovered, when comparing all rpms installed in other server and noticed that the java was not from OpenJDK. After installing the correct 1.8 version from OpenJDK all good.

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 10, 2020, 3:25pm UTC](https://discuss.elastic.co/t/logstash-load-error/217654/4 "2020-03-10T15:25:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
