# Logstash Log - \[ERROR\]\[logstash.inputs.file \] each: ignored?

**URL:** <https://discuss.elastic.co/t/logstash-log-error-logstash-inputs-file-each-ignored/124605>\
**Category:** Logstash\
**Created:** [March 19, 2018, 4:12pm UTC](https://discuss.elastic.co/t/logstash-log-error-logstash-inputs-file-each-ignored/124605 "2018-03-19T16:12:31Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![joaoantoniopereira](https://avatars.discourse-cdn.com/v4/letter/j/a88e57/32.png) [@joaoantoniopereira](https://discuss.elastic.co/u/joaoantoniopereira)\
**Post date:** [March 19, 2018, 4:12pm UTC](https://discuss.elastic.co/t/logstash-log-error-logstash-inputs-file-each-ignored/124605/1 "2018-03-19T16:12:32Z")

</div>

Hi!  
I am running Logstash in Windows and, in my input I have the following lines:

```
file {
    path => "E:/logs/firewall/*/*firewall.txt"
    start_position => "beginning"
    sincedb_path => "E:/logs/firewall/firewall_sincedb_path"
    ignore_older => 90000
}

```

I am getting these errors in the logstash log:

**[2018-03-19T00:00:54,941][ERROR][logstash.inputs.file] each: ignored?: E:/logs/firewall/2017-09-20/2017-09-firewall.txt: (#\<Errno::ESRCH: No such process - E:/logs/firewall/2017-09-20/2017-09-20\_firewall.txt\>)**

It looks like Logstash is reading from folders last modified in September which is creating a huge backlog of these error lines.  
Does anyone know what is the problem here? Why is Logstash creating these errors?  
Thanks!

---

<div class="post-metadata">

**Author:** ![m.g.d](https://avatars.discourse-cdn.com/v4/letter/m/bbe5ce/32.png) [@m.g.d](https://discuss.elastic.co/u/m.g.d)\
**Post date:** [March 24, 2018, 10:35pm UTC](https://discuss.elastic.co/t/logstash-log-error-logstash-inputs-file-each-ignored/124605/2 "2018-03-24T22:35:42Z")

</div>

Hi,

I'm facing a similar issue with Logstash. I have exactly the same type of errors than you do.  
I was doing some tests using the debug mode and I can always reproduce this. These are the steps:

1. Start Logstash with a ignore\_older config value that will make some of folder/files from the path to be ignored
2. After some time delete one of those folders/files. One log entry of this type will be written everytime the stat\_interval config value is reached.

If I do not use the ignore\_older configuration, Logstash will manage the files correctly.

Any clues about how to avoid this situation?

Thank you.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 21, 2018, 10:35pm UTC](https://discuss.elastic.co/t/logstash-log-error-logstash-inputs-file-each-ignored/124605/3 "2018-04-21T22:35:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
