# \[LOGSTASH\] logstash-filter-translate plugin

**URL:** <https://discuss.elastic.co/t/logstash-logstash-filter-translate-plugin/175996>\
**Category:** Logstash\
**Created:** [April 9, 2019, 9:28am UTC](https://discuss.elastic.co/t/logstash-logstash-filter-translate-plugin/175996 "2019-04-09T09:28:38Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Alessio\_Creo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alessio_creo/32/43381_2.png) [@Alessio\_Creo](https://discuss.elastic.co/u/Alessio_Creo)\
**Post date:** [April 9, 2019, 9:28am UTC](https://discuss.elastic.co/t/logstash-logstash-filter-translate-plugin/175996/1 "2019-04-09T09:28:39Z")

</div>

Hi there,

I've inserted in one of my Logstash pipeline the translate filter tha uses a dictionary in a Windows produced CSV file. When I was using the 6.2.4 version of logstash all was working fine. Upgrading to 6.7.0 now Logstash fails to start the pipeline unless I remove the special characters and I run dos2unix on the CSV file. This is a problem because there are users outside ELK cluster that update the CSV file periodically replacing it, so every time this will happen my pipeline will fail for the reason above.  
Something changed in Logstash or I have to update some configs?

Thank you.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 7, 2019, 9:28am UTC](https://discuss.elastic.co/t/logstash-logstash-filter-translate-plugin/175996/2 "2019-05-07T09:28:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
