# Logstash manticore worker error

**URL:** https://discuss.elastic.co/t/logstash-manticore-worker-error/254137
**Category:** Logstash
**Created:** [November 3, 2020, 10:46am UTC](https://discuss.elastic.co/t/logstash-manticore-worker-error/254137 "2020-11-03T10:46:11Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Sivajanani](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sivajanani/32/75053_2.png) [@Sivajanani](https://discuss.elastic.co/u/Sivajanani)
#### Post date: [November 3, 2020, 10:46am UTC](https://discuss.elastic.co/t/logstash-manticore-worker-error/254137/1 "2020-11-03T10:46:11Z")

</div>

I have installed logstash and am trying to run the following configuration,

`input { file { path =>"C:\Test\CSV\dev.csv" start_position =>"beginning" } } filter { csv { columns =>["Plugin","Plugin Name"] } } output { elasticsearch { hosts =>["https://10.56.34.67:9200"] user => "test" password => " *******" index =>"test" ssl => "true" ssl_certificate_verification => "false" } stdout { codec => "rubydebug" } }`

I am getting the below error,

` 2020-11-03T16:05:15,572][DEBUG][logstash.javapipeline][main] Pipeline terminated by worker error {:pipeline_id=>"main", :exception=>#<Manticore::UnknownException: Unsupported or unrecognized SSL message>, :backtrace=>["C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:37:in`block in initialize'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/manticore-0.6.4-java/lib/manticore/response.rb:79:in `call'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http_client/manticore_adapter.rb:74:in `perform\_request'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:332:in `perform_request_to_url'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:261:in `health\_check\_request'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:270:in `block in healthcheck!'", "org/jruby/RubyHash.java:1415:in `each'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:266:in `healthcheck!'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:382:in `update\_urls'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:82:in `update_initial_urls'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:76:in `start'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http\_client.rb:302:in `build_pool'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http_client.rb:64:in `initialize'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http\_client\_builder.rb:105:in `create_http_client'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/http_client_builder.rb:101:in `build'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch.rb:307:in `build_client'", "C:/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.6.2-java/lib/logstash/outputs/elasticsearch/common.rb:23:in `register'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:126:in `register'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:68:in `register'", "C:/logstash-7.9.1/logstash-core/lib/logstash/java\_pipeline.rb:226:in `block in register_plugins'", "org/jruby/RubyArray.java:1809:in `each'", "C:/logstash-7.9.1/logstash-core/lib/logstash/java\_pipeline.rb:225:in `register_plugins'", "C:/logstash-7.9.1/logstash-core/lib/logstash/java_pipeline.rb:559:in `maybe\_setup\_out\_plugins'", "C:/logstash-7.9.1/logstash-core/lib/logstash/java\_pipeline.rb:238:in `start_workers'", "C:/logstash-7.9.1/logstash-core/lib/logstash/java_pipeline.rb:183:in `run'", "C:/logstash-7.9.1/logstash-core/lib/logstash/java\_pipeline.rb:134:in `block in start'"], "pipeline.sources"=>["C:/logstash-7.9.1/config/vmlogs-windows-qadev.config"], :thread=>"#<Thread:0x1929a49a run>"} [2020-11-03T16:05:15,603][ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil} [2020-11-03T16:05:15,650][DEBUG][logstash.agent] Starting puma [2020-11-03T16:05:15,666][DEBUG][logstash.instrument.periodicpoller.os] Stopping [2020-11-03T16:05:15,681][DEBUG][logstash.instrument.periodicpoller.jvm] Stopping [2020-11-03T16:05:15,681][DEBUG][logstash.agent] Trying to start WebServer {:port=>9600} [2020-11-03T16:05:15,681][DEBUG][logstash.instrument.periodicpoller.persistentqueue] Stopping [2020-11-03T16:05:15,681][DEBUG][logstash.instrument.periodicpoller.deadletterqueue] Stopping [2020-11-03T16:05:15,697][DEBUG][logstash.agent] Shutting down all pipelines {:pipelines_count=>0} [2020-11-03T16:05:15,697][DEBUG][logstash.agent] Converging pipelines state {:actions_count=>0} [2020-11-03T16:05:15,728][DEBUG][logstash.api.service] [api-service] start [2020-11-03T16:05:15,916][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600} [2020-11-03T16:05:20,869][INFO][logstash.runner] Logstash shut down. [2020-11-03T16:05:20,885][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit `

Please suggest to resolve this issue.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 1, 2020, 10:46am UTC](https://discuss.elastic.co/t/logstash-manticore-worker-error/254137/2 "2020-12-01T10:46:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
