# Logstash monitoring with eck-operator

**URL:** <https://discuss.elastic.co/t/logstash-monitoring-with-eck-operator/377665>\
**Category:** Logstash\
**Created:** [April 30, 2025, 11:53am UTC](https://discuss.elastic.co/t/logstash-monitoring-with-eck-operator/377665 "2025-04-30T11:53:00Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jo\_De\_Troy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jo_de_troy/32/59858_2.png) [@Jo\_De\_Troy](https://discuss.elastic.co/u/Jo_De_Troy)\
**Post date:** [April 30, 2025, 11:53am UTC](https://discuss.elastic.co/t/logstash-monitoring-with-eck-operator/377665/1 "2025-04-30T11:53:00Z")

</div>

Hello all,  
has anyone tried specifying requests/limits for the metricbeat sidecar used for monitoring a logstash resource? Is there a supported way to specify these?  
My logstash fails with the message "... forbidden: failed quota: logstash-compute-resources: must specify limits.cpu for: metricbeat; limits.memory for: metricbeat; requests.cpu for: metricbeat; requests.memory for: metricbeat"} "

Best Regards,  
Jo
