# Logstash not being monitored after I installed new licenses on ES nodes

**URL:** https://discuss.elastic.co/t/logstash-not-being-monitored-after-i-installed-new-licenses-on-es-nodes/163624
**Category:** Logstash
**Tags:** elastic-stack-monitoring, elastic-stack-security
**Created:** [January 9, 2019, 9:20pm UTC](https://discuss.elastic.co/t/logstash-not-being-monitored-after-i-installed-new-licenses-on-es-nodes/163624 "2019-01-09T21:20:06Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Data77](https://avatars.discourse-cdn.com/v4/letter/d/fbc32d/32.png) [@Data77](https://discuss.elastic.co/u/Data77)
#### Post date: [January 9, 2019, 9:20pm UTC](https://discuss.elastic.co/t/logstash-not-being-monitored-after-i-installed-new-licenses-on-es-nodes/163624/1 "2019-01-09T21:20:06Z")

</div>

Hello I am using 5.6.12 Logstash, ES, and kibana (cannot use newer stuff wish I could)

Essentially I had everything working fine with my configs until I had to update my license for ES.  
i used the command in docs to send new license to ES nodes (the license was official directly from Elasticsearch representative. I can monitor my ES datanodes fine and see them in GUI kibana. I do not see logstash and I am receiving this error.

[2019-01-09T20:47:03,514][WARN][logstash.licensechecker.xpackinfo] Nil response from License Server  
[2019-01-09T20:47:04,119][INFO][logstash.outputs.elasticsearch] Running health check to see if an Elasticsearch connection is working {:healthcheck\_url=\>[http://logstash\_system:xxxxxx@10.70.70.114:9202/](http://logstash_system:xxxxxx@10.70.70.114:9202/), :path=\>"/"}  
[2019-01-09T20:47:04,128][WARN][logstash.outputs.elasticsearch] Attempted to resurrect connection to dead ES instance, but got an error. {:url=\>"[http://logstash\_system:xxxxxx@10.70.70.114:9202/](http://logstash_system:xxxxxx@10.70.70.114:9202/)", :error\_type=\>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :error=\>"Elasticsearch Unreachable: [[http://logstash\_system:xxxxxx@10.70.70.114:9202/](http://logstash_system:xxxxxx@10.70.70.114:9202/)][Manticore::ClientProtocolException] 10.70.70.114:9202 failed to respond"}

I used:  
curl -XPUT -u elastic 'http://\<host\>:\<port\>/\_xpack/license' -H "Content-Type: application/json" -d @license.json

to update both ES nodes and I havent changed anything in my configuration files or pipeline file. Any idea on how I can get logstash to recognize new license ?

thank you please assist me

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [January 10, 2019, 5:49am UTC](https://discuss.elastic.co/t/logstash-not-being-monitored-after-i-installed-new-licenses-on-es-nodes/163624/2 "2019-01-10T05:49:38Z")

</div>

> [@Data77](#):
>
> Elasticsearch::HttpClient::Pool::HostUnreachableError, :error=\>"Elasticsearch Unreachable: [[http://logstash\_system:xxxxxx@10.70.70.114:9202/](http://logstash_system:xxxxxx@10.70.70.114:9202/)][Manticore::ClientProtocolException] 10.70.70.114:9202 failed to respond"}

This doesn't look related to licensing at first sight.

- Is there an Elasticsearch node running on 10.70.70.114 ? Is it listening on port 9202 ( http layer ) ?
- Is that Elasticseach node healthy? Can you check its logs, I'd expect to find some ERROR messages or some indication that it is not running
- Did something change in your network? Can you access 10.70.70.114 from the machine running Logstash?

---

<div class="post-metadata">

### Author: ![Data77](https://avatars.discourse-cdn.com/v4/letter/d/fbc32d/32.png) [@Data77](https://discuss.elastic.co/u/Data77)
#### Post date: [January 10, 2019, 4:13pm UTC](https://discuss.elastic.co/t/logstash-not-being-monitored-after-i-installed-new-licenses-on-es-nodes/163624/3 "2019-01-10T16:13:52Z")

</div>

I resolved the issue in a weird way by setting pack.security.http.ssl.enabled: from true to false in all YML files. this locked me out from Kibana so I changed them all back to true and now logstash is being monitored again.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 7, 2019, 4:13pm UTC](https://discuss.elastic.co/t/logstash-not-being-monitored-after-i-installed-new-licenses-on-es-nodes/163624/4 "2019-02-07T16:13:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
