# Logstash not logging & failing after start of elasticsearch

**URL:** <https://discuss.elastic.co/t/logstash-not-logging-failing-after-start-of-elasticsearch/247501>\
**Category:** Logstash\
**Created:** [September 4, 2020, 8:23am UTC](https://discuss.elastic.co/t/logstash-not-logging-failing-after-start-of-elasticsearch/247501 "2020-09-04T08:23:54Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![apurvakhatri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/apurvakhatri/32/69819_2.png) [@apurvakhatri](https://discuss.elastic.co/u/apurvakhatri)\
**Post date:** [September 4, 2020, 8:23am UTC](https://discuss.elastic.co/t/logstash-not-logging-failing-after-start-of-elasticsearch/247501/1 "2020-09-04T08:23:54Z")

</div>

Here is the process:

> sudo service logstash start

> sudo service logstash status

```auto
     logstash.service - logstash
       Loaded: loaded (/etc/systemd/system/logstash.service; disabled; vendor preset : disabled)
       Active: **active** (running) since Fri 2020-09-04 13:43:05 IST; 8s ago

```

> sudo service elasticsearch start

```auto
Starting elasticsearch (via systemctl): [OK]

```

> sudo service elasticsearch status

```auto
elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/elasticsearch.service.d
           └─startup-timeout.conf
   Active: **active** (running) 

```

> sudo service logstash status

```auto
logstash.service - logstash
   Loaded: loaded (/etc/systemd/system/logstash.service; disabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Fri 2020-09-04 13:46:24 IST; 1min 11s ago
  Process: xxxxx ExecStart=/usr/share/logstash/bin/logstash --path.settings /etc/logstash (code=exited, status=1/FAILURE)
 Main PID: xxxxx (code=exited, status=1/FAILURE)

Sep 04 13:46:24 ip-x-y-z-r systemd[1]: Unit logstash.service entered failed state.
Sep 04 13:46:24 ip-x-y-z-r systemd[1]: logstash.service failed.
Sep 04 13:46:24 ip-x-y-z-r systemd[1]: logstash.service holdoff time over, scheduling restart.
Sep 04 13:46:24 ip-x-y-z-r systemd[1]: Stopped logstash.
Sep 04 13:46:24 ip-x-y-z-r systemd[1]: start request repeated too quickly for logstash.service
Sep 04 13:46:24 ip-x-y-z-r systemd[1]: Failed to start logstash.
Sep 04 13:46:24 ip-x-y-z-r systemd[1]: Unit logstash.service entered failed state.
Sep 04 13:46:24 ip-x-y-z-r systemd[1]: logstash.service failed.

```

Now, When i visit /var/log/logstash/logstash-plain.log it is not updated.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 2, 2020, 8:24am UTC](https://discuss.elastic.co/t/logstash-not-logging-failing-after-start-of-elasticsearch/247501/2 "2020-10-02T08:24:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
