# Logstash not sending to ES when date parsing fails

**URL:** https://discuss.elastic.co/t/logstash-not-sending-to-es-when-date-parsing-fails/45243
**Category:** Logstash
**Created:** [March 23, 2016, 3:37pm UTC](https://discuss.elastic.co/t/logstash-not-sending-to-es-when-date-parsing-fails/45243 "2016-03-23T15:37:24Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![dcroonen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dcroonen/32/27450_2.png) [@dcroonen](https://discuss.elastic.co/u/dcroonen)
#### Post date: [March 23, 2016, 3:37pm UTC](https://discuss.elastic.co/t/logstash-not-sending-to-es-when-date-parsing-fails/45243/1 "2016-03-23T15:37:24Z")

</div>

Hi

I have an epoch timestamp which I want to get into the @timestamp field in Elasticsearch/Kibana. When I use the code:

date {  
match =\> ["slowlog\_timestamp","UNIX"]  
remove\_field =\> ["slowlog\_timestamp"]  
}

I get a \_dateparsefailure and nothing is to be send to Elasticsearch/Kibana. When I use the code:

date {  
match =\> ["slowlog\_timestamp","UNIX"]  
remove\_field =\> ["slowlog\_timestamp"]  
target =\> "myTime"  
}

I get no \_dateparsefailure and the event ends up in Elasticsearch/Kibana (see screenshot).

Anybody any ideas?

Thanks in advance.

Regards  
Davy

![](https://us1.discourse-cdn.com/elastic/original/2X/5/57a6f2db0ee2b24d231862b2edf58f32cdcdd737.png)

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [March 24, 2016, 7:24pm UTC](https://discuss.elastic.co/t/logstash-not-sending-to-es-when-date-parsing-fails/45243/2 "2016-03-24T19:24:40Z")

</div>

What does the raw message that results in `_dateparsefailure` look like? I'm interested in what the `slowlog_timestamp` field looks like.

---

<div class="post-metadata">

### Author: ![dcroonen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dcroonen/32/27450_2.png) [@dcroonen](https://discuss.elastic.co/u/dcroonen)
#### Post date: [March 25, 2016, 12:33pm UTC](https://discuss.elastic.co/t/logstash-not-sending-to-es-when-date-parsing-fails/45243/3 "2016-03-25T12:33:17Z")

</div>

Hi Magnus

Thanks for your response. After a lot of debugging I finally found the root cause of my problem. Because I was using (old) logdata from a production server over and over again and because I was modifying the timestamp field, Elasticsearch putted the shipped data in another (older) index then the one (current) I was looking at (really pebkac isn't it).

The \_dateparsefailure mentioned was also caused by me because I was trying to do incorrect conversions in an effort to debug the problem but looking in the wrong the direction.

Thanks again and sorry for (wasting) your time.

Regards

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 5:05am UTC](https://discuss.elastic.co/t/logstash-not-sending-to-es-when-date-parsing-fails/45243/4 "2017-07-06T05:05:22Z")

</div>


