# Logstash not working as a service

**URL:** <https://discuss.elastic.co/t/logstash-not-working-as-a-service/299600>\
**Category:** Logstash\
**Created:** [March 14, 2022, 10:41am UTC](https://discuss.elastic.co/t/logstash-not-working-as-a-service/299600 "2022-03-14T10:41:36Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ashiqab](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ashiqab/32/103144_2.png) [@ashiqab](https://discuss.elastic.co/u/ashiqab)\
**Post date:** [March 14, 2022, 10:41am UTC](https://discuss.elastic.co/t/logstash-not-working-as-a-service/299600/1 "2022-03-14T10:41:36Z")

</div>

Hello,

I am new to ELK and am trying to set up monitoring on few of our application jobs using ELK stack. I could run the below query successfully and the data is reflecting on Kibana:

logstash -f /etc/logstash/conf.d/accessinfologs.conf

However when i try to set up logstash service, it fails with the below error:

_Mar 14 11:38:55 vlcdbdd2 logstash[28237]: [2022-03-14T11:38:55,407][FATAL][logstash.runner] An unexpected error occurred! {:error=\>java.nio.file.AccessDeniedException: /usr/share/logstash/data/.lock, :backtrace=\>["sun.nio.fs.UnixException.translateToIOException(sun/nio/fs/UnixException.java:90)", "sun.nio.fs.UnixException.rethrowAsIOException(sun/nio/fs/UnixException.java:111)", "sun.nio.fs.UnixException.rethrowAsIOException(sun/nio/fs/UnixException.java:116)", "sun.nio.fs.UnixFileSystemProvider.newFileChannel(sun/nio/fs/UnixFileSystemProvider.java:182)", "java.nio.channels.FileChannel.open(java/nio/channels/FileChannel.java:292)", "java.nio.channels.FileChannel.open(java/nio/channels/FileChannel.java:345)", "org.logstash.FileLockFactory.obtainLock(org/logstash/FileLockFactory.java:89)", "jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)", "jdk.internal.reflect.NativeMethodAccessorImpl.invoke(jdk/internal/reflect/NativeMethodAccessorImpl.java:62)", "jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(jdk/internal/reflect/DelegatingMethodAccessorImpl.java:43)", "java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:566)", "org.jruby.javasupport.JavaMethod.invokeDirectWithExceptionHandling(org/jruby/javasupport/JavaMethod.java:471)", "org.jruby.javasupport.JavaMethod.invokeStaticDirect(org/jruby/javasupport/JavaMethod.java:373)", "RUBY.execute(/usr/share/logstash/logstash-core/lib/logstash/runner.rb:396)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.clamp\_minus\_1\_dot\_0\_dot\_1.lib.clamp.command.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-1.0.1/lib/clamp/command.rb:68)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.runner.run(/usr/share/logstash/logstash-core/lib/logstash/runner.rb:282)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.clamp\_minus\_1\_dot\_0\_dot\_1.lib.clamp.command.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/clamp-1.0.1/lib/clamp/command.rb:133)", "usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environm_  
_Mar 14 11:38:55 vlcdbdd2 logstash[28237]: ent.rb:93)", "java.lang.invoke.MethodHandle.invokeWithArguments(java/lang/invoke/MethodHandle.java:710)", "org.jruby.Ruby.runScript(org/jruby/Ruby.java:1205)", "org.jruby.Ruby.runNormally(org/jruby/Ruby.java:1128)", "org.jruby.Ruby.runNormally(org/jruby/Ruby.java:1146)", "org.jruby.Ruby.runFromMain(org/jruby/Ruby.java:958)", "org.logstash.Logstash.run(org/logstash/Logstash.java:163)", "org.logstash.Logstash.main(org/logstash/Logstash.java:73)"]}_  
_Mar 14 11:38:55 vlcdbdd2 logstash[28237]: [2022-03-14T11:38:55,421][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit_

Here is my logstash.yml file:

_pipeline.batch.size: 125_

- pipeline.batch.delay: 5\*
- node.name: dlmlogstash\*  
_path.data: /var/lib/logstash_
- pipeline.id: main\*
- pipeline.workers: 2\*  
_path.config:/etc/logstash/conf.d/_  
_log.level: info_  
_path.logs: /var/log/logstash_  
_xpack.monitoring.enabled: true_  
_xpack.monitoring.Elasticsearch.username: elastic_  
_xpack.monitoring.Elasticsearch.password: passwd_  
_xpack.monitoring.Elasticsearch.hosts: ["[http://10.177.36.103:9200](http://10.177.36.103:9200)"]_

Could you please guide me to the right area I should focus on in order to set up logstash service.

Thanks and regards,  
Ashiq Aboo Backer

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [March 14, 2022, 4:56pm UTC](https://discuss.elastic.co/t/logstash-not-working-as-a-service/299600/2 "2022-03-14T16:56:59Z")

</div>

> [@ashiqab](#):
>
> java.nio.file.AccessDeniedException: /usr/share/logstash/data/.lock

logstash is trying to write to that file and is getting an exception. You need to check that the permissions allow the directory and file to be written to by whatever user logstash is running as.

---

<div class="post-metadata">

**Author:** ![ashiqab](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ashiqab/32/103144_2.png) [@ashiqab](https://discuss.elastic.co/u/ashiqab)\
**Post date:** [March 15, 2022, 3:19am UTC](https://discuss.elastic.co/t/logstash-not-working-as-a-service/299600/3 "2022-03-15T03:19:26Z")

</div>

> [@ashiqab](#):
>
> usr

Thank you so much! I think my chown skipped this hidden file. It works fine now! 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 12, 2022, 3:20am UTC](https://discuss.elastic.co/t/logstash-not-working-as-a-service/299600/4 "2022-04-12T03:20:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
