# Logstash not working in docker

**URL:** <https://discuss.elastic.co/t/logstash-not-working-in-docker/273748>\
**Category:** Logstash\
**Created:** [May 23, 2021, 5:15am UTC](https://discuss.elastic.co/t/logstash-not-working-in-docker/273748 "2021-05-23T05:15:40Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shubham\_Pachpande](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shubham_pachpande/32/80579_2.png) [@Shubham\_Pachpande](https://discuss.elastic.co/u/Shubham_Pachpande)\
**Post date:** [May 23, 2021, 5:15am UTC](https://discuss.elastic.co/t/logstash-not-working-in-docker/273748/1 "2021-05-23T05:15:40Z")

</div>

Using bundled JDK: /usr/share/logstash/jdk  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
Sending Logstash logs to /usr/share/logstash/logs which is now configured via log4j2.properties  
[2021-05-23T05:11:49,727][INFO][logstash.runner] Log4j configuration path used is: /usr/share/logstash/config/log4j2.properties  
[2021-05-23T05:11:49,739][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.12.1", "jruby.version"=\>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc OpenJDK 64-Bit Server VM 11.0.10+9 on 11.0.10+9 +indy +jit [linux-x86\_64]"}  
[2021-05-23T05:11:49,766][INFO][logstash.setting.writabledirectory] Creating directory {:setting=\>"path.queue", :path=\>"/usr/share/logstash/data/queue"}  
[2021-05-23T05:11:49,781][INFO][logstash.setting.writabledirectory] Creating directory {:setting=\>"path.dead\_letter\_queue", :path=\>"/usr/share/logstash/data/dead\_letter\_queue"}  
[2021-05-23T05:11:50,361][INFO][logstash.agent] No persistent UUID file found. Generating new UUID {:uuid=\>"87f1617a-88b8-4af0-9f73-3d4777900771", :path=\>"/usr/share/logstash/data/uuid"}  
[2021-05-23T05:11:50,867][WARN][logstash.monitoringextension.pipelineregisterhook] xpack.monitoring.enabled has not been defined, but found elasticsearch configuration. Please explicitly set `xpack.monitoring.enabled: true` in logstash.yml  
[2021-05-23T05:11:50,871][WARN][deprecation.logstash.monitoringextension.pipelineregisterhook] Internal collectors option for Logstash monitoring is deprecated and targeted for removal in the next major version.  
Please configure Metricbeat to monitor Logstash. Documentation can be found at:

> **[Collect Logstash monitoring data with Metricbeat | Logstash Reference \[7.12\]...](https://www.elastic.co/guide/en/logstash/current/monitoring-with-metricbeat.html)**

[2021-05-23T05:11:51,351][WARN][deprecation.logstash.outputs.elasticsearch] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2021-05-23T05:11:52,006][INFO][logstash.licensechecker.licensereader] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://elasticsearch:9200/](http://elasticsearch:9200/)]}}  
[2021-05-23T05:11:52,390][WARN][logstash.licensechecker.licensereader] Restored connection to ES instance {:url=\>"[http://elasticsearch:9200/](http://elasticsearch:9200/)"}  
[2021-05-23T05:11:52,472][INFO][logstash.licensechecker.licensereader] ES Output version determined {:es\_version=\>7}  
[2021-05-23T05:11:52,476][WARN][logstash.licensechecker.licensereader] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>7}  
[2021-05-23T05:11:52,627][INFO][logstash.monitoring.internalpipelinesource] Monitoring License OK  
[2021-05-23T05:11:52,629][INFO][logstash.monitoring.internalpipelinesource] Validated license for monitoring. Enabling monitoring pipeline.  
[2021-05-23T05:11:53,103][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2021-05-23T05:11:53,177][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of [\t\r\n], "#", "input", "filter", "output" at line 1, column 1 (byte 1)", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:32:in `compile_imperative'", "org/logstash/execution/AbstractPipelineExt.java:184:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:69:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:47:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:52:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:389:in `block in converge\_state'"]}  
[2021-05-23T05:11:54,272][INFO][org.reflections.Reflections] Reflections took 44 ms to scan 1 urls, producing 23 keys and 47 values  
[2021-05-23T05:11:54,416][WARN][deprecation.logstash.outputs.elasticsearchmonitoring] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2021-05-23T05:11:54,526][INFO][logstash.outputs.elasticsearchmonitoring][.monitoring-logstash] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://elasticsearch:9200/](http://elasticsearch:9200/)]}}  
[2021-05-23T05:11:54,547][WARN][logstash.outputs.elasticsearchmonitoring][.monitoring-logstash] Restored connection to ES instance {:url=\>"[http://elasticsearch:9200/](http://elasticsearch:9200/)"}  
[2021-05-23T05:11:54,558][INFO][logstash.outputs.elasticsearchmonitoring][.monitoring-logstash] ES Output version determined {:es\_version=\>7}  
[2021-05-23T05:11:54,559][WARN][logstash.outputs.elasticsearchmonitoring][.monitoring-logstash] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>7}  
[2021-05-23T05:11:54,668][INFO][logstash.outputs.elasticsearchmonitoring][.monitoring-logstash] New Elasticsearch output {:class=\>"LogStash::Outputs::ElasticSearchMonitoring", :hosts=\>["[http://elasticsearch:9200](http://elasticsearch:9200)"]}  
[2021-05-23T05:11:54,679][WARN][logstash.javapipeline][.monitoring-logstash] 'pipeline.ordered' is enabled and is likely less efficient, consider disabling if preserving event order is not necessary  
[2021-05-23T05:11:54,767][INFO][logstash.javapipeline][.monitoring-logstash] Starting pipeline {:pipeline\_id=\>".monitoring-logstash", "pipeline.workers"=\>1, "pipeline.batch.size"=\>2, "pipeline.batch.delay"=\>50, "pipeline.max\_inflight"=\>2, "pipeline.sources"=\>["monitoring pipeline"], :thread=\>"#\<Thread:0x7e743d7e@/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:54 run\>"}  
[2021-05-23T05:11:55,648][INFO][logstash.javapipeline][.monitoring-logstash] Pipeline Java execution initialization time {"seconds"=\>0.88}  
[2021-05-23T05:11:55,696][INFO][logstash.javapipeline][.monitoring-logstash] Pipeline started {"pipeline.id"=\>".monitoring-logstash"}  
[2021-05-23T05:11:57,675][INFO][logstash.javapipeline][.monitoring-logstash] Pipeline terminated {"pipeline.id"=\>".monitoring-logstash"}  
[2021-05-23T05:11:57,949][INFO][logstash.runner] Logstash shut down.

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [May 23, 2021, 7:15pm UTC](https://discuss.elastic.co/t/logstash-not-working-in-docker/273748/2 "2021-05-23T19:15:09Z")

</div>

Hello,

Please explain what you are trying to do and what is the error to give some context, also use the `</>` to paste your log in a formatted way.

You have some errors in your configuration, you need to share your pipeline configuration.

```auto
[2021-05-23T05:11:53,177][ERROR][logstash.agent] Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:main, :exception=>"LogStash::ConfigurationError", :message=>"Expected one of [\t\r\n], "#", "input", "filter", "output" at line 1, column 1 (byte 1)",

```

This means that you have a configuration error.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 20, 2021, 7:15pm UTC](https://discuss.elastic.co/t/logstash-not-working-in-docker/273748/3 "2021-06-20T19:15:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
