# Logstash not working when started via systemctl, however it work when manually starting

**URL:** <https://discuss.elastic.co/t/logstash-not-working-when-started-via-systemctl-however-it-work-when-manually-starting/258973>\
**Category:** Logstash\
**Created:** [December 17, 2020, 10:20am UTC](https://discuss.elastic.co/t/logstash-not-working-when-started-via-systemctl-however-it-work-when-manually-starting/258973 "2020-12-17T10:20:39Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![baljka](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/baljka/32/82510_2.png) [@baljka](https://discuss.elastic.co/u/baljka)\
**Post date:** [December 17, 2020, 10:20am UTC](https://discuss.elastic.co/t/logstash-not-working-when-started-via-systemctl-however-it-work-when-manually-starting/258973/1 "2020-12-17T10:20:39Z")

</div>

Hello,

Everything was working fine. However it suddenly stopped working.  
Now when I try running command "/usr/share/logstash/bin/logstash --path.settings /etc/logstash" manually, it works fine

When I run command "systemctl start logstash". it doesn't start and doesn't create log (/var/log/logstash/).  
I run "systemctl status logstash.service". Following shows:

```bash
 [root@localhost ~]# systemctl status logstash -l
     ● logstash.service
        Loaded: loaded (/etc/systemd/system/logstash.service; bad; vendor preset: disabled)
        Active: failed (Result: start-limit) since Thu 2020-12-17 17:40:42 +08; 22min ago
       Process: 19961 ExecStart=/usr/share/logstash/bin/logstash --path.settings /etc/logstash (code=exited, status=127)
      Main PID: 19961 (code=exited, status=127)
 
     localhost.localdomain systemd[1]: Unit logstash.service entered failed state.
     localhost.localdomain systemd[1]: logstash.service failed.
     localhost.localdomain systemd[1]: logstash.service holdoff time over, scheduling restart.
     localhost.localdomain systemd[1]: Stopped logstash.service.
     localhost.localdomain systemd[1]: start request repeated too quickly for logstash.service
     localhost.localdomain systemd[1]: Failed to start logstash.service.
     localhost.localdomain systemd[1]: Unit logstash.service entered failed state.
     localhost.localdomain systemd[1]: logstash.service failed.

```

What's the problem? Any help is appreciated.

Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 14, 2021, 10:20am UTC](https://discuss.elastic.co/t/logstash-not-working-when-started-via-systemctl-however-it-work-when-manually-starting/258973/2 "2021-01-14T10:20:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
