# Logstash of first node getting stopped after adding second node into cluster, added ilm\_enabled=false

**URL:** <https://discuss.elastic.co/t/logstash-of-first-node-getting-stopped-after-adding-second-node-into-cluster-added-ilm-enabled-false/253518>\
**Category:** Logstash\
**Created:** [October 28, 2020, 4:34am UTC](https://discuss.elastic.co/t/logstash-of-first-node-getting-stopped-after-adding-second-node-into-cluster-added-ilm-enabled-false/253518 "2020-10-28T04:34:43Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![kkhadka](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kkhadka/32/74848_2.png) [@kkhadka](https://discuss.elastic.co/u/kkhadka)\
**Post date:** [October 28, 2020, 4:34am UTC](https://discuss.elastic.co/t/logstash-of-first-node-getting-stopped-after-adding-second-node-into-cluster-added-ilm-enabled-false/253518/1 "2020-10-28T04:34:43Z")

</div>

The ERROR logs are as follow:

> [2020-10-12T17:52:25,998][ERROR][logstash.outputs.elasticsearch][events] Failed to install template. {:message=\>"Elasticsearch Unreachable: [[http://164](http://164).\*\*.185.202:9200/][Manticore::SocketException] Connection refused (Connection refused)", :class=\>"LogStash::Outputs::Elasticsearch::HttpClient::Pool::HostUnreachableError", :backtrace=\>["logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:293:in perform\_request\_to\_url'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:278:in block in perform\_request'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:373:in with\_connection'", logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:277:in perform\_request'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:285:in block in Pool'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http\_client.rb:162:in get'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/http\_client.rb:378:in get\_xpack\_info'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/ilm.rb:57:in ilm\_ready?'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/ilm.rb:28:in ilm\_in\_use?'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/template\_manager.rb:14:in install\_template'",  
> logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/common.rb:130:in install\_template'", "logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.1.0-java/lib/logstash/outputs/elasticsearch/common.rb:51:in block in setup\_after\_successful\_connection'"]}  
> [2020-10-12T17:52:26,037][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Then as per this [Proposed logstash\_writer role has insufficient privileges to set up ILM · Issue #10722 · elastic/logstash · GitHub](https://github.com/elastic/logstash/issues/10722)  
I set ilm\_enabled=false for all the logstash configurations.  
What will be the impact of this change on my cluster?

---

<div class="post-metadata">

**Author:** ![kkhadka](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kkhadka/32/74848_2.png) [@kkhadka](https://discuss.elastic.co/u/kkhadka)\
**Post date:** [November 3, 2020, 9:29am UTC](https://discuss.elastic.co/t/logstash-of-first-node-getting-stopped-after-adding-second-node-into-cluster-added-ilm-enabled-false/253518/2 "2020-11-03T09:29:01Z")

</div>

Could someone please help with this query?

---

<div class="post-metadata">

**Author:** ![BBQigniter](https://avatars.discourse-cdn.com/v4/letter/b/3da27b/32.png) [@BBQigniter](https://discuss.elastic.co/u/BBQigniter)\
**Post date:** [November 3, 2020, 1:23pm UTC](https://discuss.elastic.co/t/logstash-of-first-node-getting-stopped-after-adding-second-node-into-cluster-added-ilm-enabled-false/253518/3 "2020-11-03T13:23:44Z")

</div>

```auto
Elasticsearch Unreachable: [http://164.**.185.202:9200/][Manticore::SocketException] Connection refused (Connection refused)

```

for me it just looks like logstash cannot connect to your elasticsearch at all and so stops working.

---

<div class="post-metadata">

**Author:** ![kkhadka](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kkhadka/32/74848_2.png) [@kkhadka](https://discuss.elastic.co/u/kkhadka)\
**Post date:** [November 3, 2020, 2:01pm UTC](https://discuss.elastic.co/t/logstash-of-first-node-getting-stopped-after-adding-second-node-into-cluster-added-ilm-enabled-false/253518/4 "2020-11-03T14:01:43Z")

</div>

@BBQigniter yeah, when the second node adds into the cluster that time it may not be able to connect to ElasticSearch.  
I want to know if there is any impact of setting `ilm_enabled = false` for any of the services.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 1, 2020, 2:01pm UTC](https://discuss.elastic.co/t/logstash-of-first-node-getting-stopped-after-adding-second-node-into-cluster-added-ilm-enabled-false/253518/5 "2020-12-01T14:01:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
