# Logstash on Solaris - stat.st\_gid unsupported or native support failed to load \[SOLVED\]

**URL:** https://discuss.elastic.co/t/logstash-on-solaris-stat-st-gid-unsupported-or-native-support-failed-to-load-solved/24166
**Category:** Logstash
**Created:** [June 23, 2015, 9:05am UTC](https://discuss.elastic.co/t/logstash-on-solaris-stat-st-gid-unsupported-or-native-support-failed-to-load-solved/24166 "2015-06-23T09:05:21Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Thorsten\_Nickel](https://avatars.discourse-cdn.com/v4/letter/t/3be4f8/32.png) [@Thorsten\_Nickel](https://discuss.elastic.co/u/Thorsten_Nickel)
#### Post date: [June 23, 2015, 9:05am UTC](https://discuss.elastic.co/t/logstash-on-solaris-stat-st-gid-unsupported-or-native-support-failed-to-load-solved/24166/1 "2015-06-23T09:05:22Z")

</div>

Dear all,

as I am using Logstash only swith Solaris SPARC environment, I really had the hope that with the freshly released V1.5.1 I would no more run across this error. But I still did, as this example shows:

```
$ ./bin/logstash -V
    io/console not supported; tty will not be manipulated
    logstash 1.5.1

    user@host :/tools/logstash
    $ ./bin/logstash -f config/test.conf
    io/console not supported; tty will not be manipulated
    NotImplementedError: stat.st_gid unsupported or native support failed to load
                 gid at org/jruby/RubyFileStat.java:247
        atomic_write at /tools/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/helper.rb:45
      _sincedb_write at /tools/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/tail.rb:234
       sincedb_write at /tools/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.3/lib/filewatch/tail.rb:204
            teardown at /tools/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-file-0.1.10/lib/logstash/inputs/file.rb:151
         inputworker at /tools/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:202
         synchronize at org/jruby/ext/thread/Mutex.java:149
         inputworker at /tools/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:202
         start_input at /tools/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.1-java/lib/logstash/pipeline.rb:170
```

But after reading through all the linked entries regarding this error it all boiled down to quite a simple fact. It looked like a crypto-library was bugging me out, on whatever reason.  
System-Traces pointed to the 'libcryptoutil' as the library in question, so I digged for it

```
$ find /usr/lib -name 'libcryptoutil*' -ls
 2008 1 lrwxrwxrwx 1 root root 18 Mar 27 2009 /usr/lib/sparcv9/libcryptoutil.so -> libcryptoutil.so.1
 2245 61 -rwxr-xr-x 1 root bin 62336 Aug 10 2010 /usr/lib/sparcv9/libcryptoutil.so.1
 1792 1 lrwxrwxrwx 1 root root 20 Mar 27 2009 /usr/lib/libcryptoutil.so -> ./libcryptoutil.so.1
 2151 55 -rwxr-xr-x 1 root bin 55376 Aug 10 2010 /usr/lib/libcryptoutil.so.1
```

So, I got this library twice, somehow. Then, I forced the path into using the sparc version of this library like so:

```
$ export LD_LIBRARY_PATH=/usr/lib/sparcv9/:$LD_LIBRARY_PATH

user@host :/tools/logstash
$ ./bin/logstash -f config/test.conf
io/console not supported; tty will not be manipulated
Logstash startup completed
^C
SIGINT received. Shutting down the pipeline. {:level=>:warn}
Logstash shutdown completed
```

So finally, after correcting my LD Path, I got everything running.

Hopefully this may help other users as well.

Kind Regards,  
T. Nickel

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 23, 2015, 9:09am UTC](https://discuss.elastic.co/t/logstash-on-solaris-stat-st-gid-unsupported-or-native-support-failed-to-load-solved/24166/2 "2015-06-23T09:09:34Z")

</div>

Thanks for sharing the solution 😃

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 5:36am UTC](https://discuss.elastic.co/t/logstash-on-solaris-stat-st-gid-unsupported-or-native-support-failed-to-load-solved/24166/3 "2017-07-06T05:36:45Z")

</div>


