# Logstash optional client cert authentication/validation

**URL:** https://discuss.elastic.co/t/logstash-optional-client-cert-authentication-validation/122341
**Category:** Beats
**Created:** [March 3, 2018, 12:12am UTC](https://discuss.elastic.co/t/logstash-optional-client-cert-authentication-validation/122341 "2018-03-03T00:12:16Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Archit\_Baweja](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/archit_baweja/32/28370_2.png) [@Archit\_Baweja](https://discuss.elastic.co/u/Archit_Baweja)
#### Post date: [March 3, 2018, 12:12am UTC](https://discuss.elastic.co/t/logstash-optional-client-cert-authentication-validation/122341/1 "2018-03-03T00:12:16Z")

</div>

Hey folks,

I'm trying to setup filebeat/metric client authentication in logstash. I followed the article at [https://www.elastic.co/guide/en/beats/filebeat/current/configuring-ssl-logstash.html](https://www.elastic.co/guide/en/beats/filebeat/current/configuring-ssl-logstash.html)

I currently have a fleet of filebeats deployed with no client certs. So I chose the `option ssl_verify_mode => "peer"`, so that my existing filebeats/metricbeat fleet can still connect and send logs, while I test out my client cert configuration in a test filebeat. However my existing filebeat/metricbeats are unable to connect. I see the following error in my logstash logs

{  
"level": "INFO",  
"loggerName": "org.logstash.beats.BeatsHandler",  
"timeMillis": 1520035579443,  
"thread": "defaultEventExecutorGroup-5-8",  
"logEvent": {  
"message": "[local: 0.0.0.0:5044, remote: 10.0.0.65:27085] Handling exception: javax.net.ssl.SSLHandshakeException: error:100000c0:SSL routines:OPENSSL\_internal:PEER\_DID\_NOT\_RETURN\_A\_CERTIFICATE"  
}  
}

Am I misunderstanding the difference between force\_peer v/s peer option for ssl\_verify\_mode?

UPDATE: I'm using logstash-6.1.2 and filebeat-6.1.2.  
UPDATE 2: Have Openssl 1.0.2k-fips on Amazon Linux.

When testing connection with openssl s\_client form my filebeat node, I get the following message: "Verify return code; 0 (ok)".

Thanks in advance,  
Archit

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 31, 2018, 2:12am UTC](https://discuss.elastic.co/t/logstash-optional-client-cert-authentication-validation/122341/2 "2018-03-31T02:12:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
