# Logstash plugin error with Tibero DB

**URL:** <https://discuss.elastic.co/t/logstash-plugin-error-with-tibero-db/363832>\
**Category:** Logstash\
**Created:** [July 26, 2024, 7:57am UTC](https://discuss.elastic.co/t/logstash-plugin-error-with-tibero-db/363832 "2024-07-26T07:57:29Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![jimmy\_park](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jimmy_park/32/136320_2.png) [@jimmy\_park](https://discuss.elastic.co/u/jimmy_park)\
**Post date:** [July 26, 2024, 7:57am UTC](https://discuss.elastic.co/t/logstash-plugin-error-with-tibero-db/363832/1 "2024-07-26T07:57:29Z")

</div>

I have a problem about using Logstash with Tibero DB

I want to extract data using Logstash at Tibero DB  
But the plugin error is occured

My test.conf is:

> input {  
> jdbc {  
> jdbc\_driver\_library =\> "/home/elastic/tibero6-jdbc.jar"  
> jdbc\_driver\_class =\> "com.tmax.tibero.jdbc.TbDriver"  
> jdbc\_connection\_string =\> "jdbc:tibero:thin@[IP]:[Port]:tibero"  
> jdbc\_user =\> "sys"  
> jdbc\_password =\> "tibero"  
> statement =\> "SELECT 1 FROM DUAL;"  
> }  
> }  
> output {  
> stdout {}  
> }

There is no problem with this by entering the actual values ​​used for IP and Port.

The error code is :

> Pipeline error {:pipeline\_id=\>"main", :exception=\>#\<LogStash::ConfigurationError: Can't create a connection pool to the database\>, :backtrace=\>["/home/elastic/logstash-8.12.2/vendor/bundle/jruby/3.1.0/gems/logstash-integration-jdbc-5.4.8/lib/logstash/inputs/jdbc.rb:318:in `register'", "/home/elastic/logstash-8.12.2/vendor/bundle/jruby/3.1.0/gems/logstash-mixin-ecs_compatibility_support-1.3.0-java/lib/logstash/plugin_mixins/ecs_compatibility_support/target_check.rb:48:in `register'", "/home/elastic/logstash-8.12.2/logstash-core/lib/logstash/java\_pipeline.rb:237:in `block in register_plugins'", "org/jruby/RubyArray.java:1989:in `each'", "/home/elastic/logstash-8.12.2/logstash-core/lib/logstash/java\_pipeline.rb:236:in `register_plugins'", "/home/elastic/logstash-8.12.2/logstash-core/lib/logstash/java_pipeline.rb:395:in `start\_inputs'", "/home/elastic/logstash-8.12.2/logstash-core/lib/logstash/java\_pipeline.rb:320:in `start_workers'", "/home/elastic/logstash-8.12.2/logstash-core/lib/logstash/java_pipeline.rb:194:in `run'", "/home/elastic/logstash-8.12.2/logstash-core/lib/logstash/java\_pipeline.rb:146:in `block in start'"], "pipeline.sources"=\>["/home/elastic/logstash-8.12.2/config/test.conf"], :thread=\>"#\<Thread:0x624125c5 /home/elastic/logstash-8.12.2/logstash-core/lib/logstash/java\_pipeline.rb:134 run\>"}

I think Logstash doesn't support Tibero DB

Is it right?

I want to know Logstash support Tibero DB JDBC

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [July 26, 2024, 11:35am UTC](https://discuss.elastic.co/t/logstash-plugin-error-with-tibero-db/363832/2 "2024-07-26T11:35:33Z")

</div>

The [code will log](https://github.com/logstash-plugins/logstash-integration-jdbc/blob/c0061a6f14f0b1ebf96b4141b44fb822a3e8f881/lib/logstash/inputs/jdbc.rb#L317) a warning before raising that exception. What is the warning?

---

<div class="post-metadata">

**Author:** ![jimmy\_park](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jimmy_park/32/136320_2.png) [@jimmy\_park](https://discuss.elastic.co/u/jimmy_park)\
**Post date:** [July 26, 2024, 12:21pm UTC](https://discuss.elastic.co/t/logstash-plugin-error-with-tibero-db/363832/3 "2024-07-26T12:21:53Z")

</div>

I checked the log you said.  
I checked the error in my first log, and I found the cause of error.

I checked my config file,  
I forgot ':' while copying the jdbc\_connection\_string.

Before the string is "jdbc:tibero:thin@[IP]:[Port]:tibero",  
but the string should have been "jdbc:tibero:thin:@[IP]:[Port]:tibero"

And the firewall problem...  
It is not worked because the firewall

So, I solved the problem, now

Thanks for your help 🙂
