# Logstash-plugin fails with java errors on a clean install

**URL:** <https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744>\
**Category:** Logstash\
**Created:** [September 7, 2017, 3:35pm UTC](https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744 "2017-09-07T15:35:46Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![rrue](https://avatars.discourse-cdn.com/v4/letter/r/bb73d2/32.png) [@rrue](https://discuss.elastic.co/u/rrue)\
**Post date:** [September 7, 2017, 3:35pm UTC](https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744/1 "2017-09-07T15:35:46Z")

</div>

Hi All,

Forgive what is likely a newbie question, I'm pretty green around ELK and especially ruby and gems.

Just installed LS 5.5.2 via RPM to openSUSE LEAP 42.2 and if I cd to /usr/share/logstash and try to run any call to ./bin/logstash-plugin (e.g. list, install, or with no arguments) I get:

relk-a:/usr/share/logstash # ./bin/logstash-plugin  
LoadError: load error: jopenssl/load -- java.lang.InternalError: null  
require at org/jruby/RubyKernel.java:1040  
require at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:54  
(root) at /usr/share/logstash/vendor/jruby/lib/ruby/shared/openssl.rb:1  
require at org/jruby/RubyKernel.java:1040  
(root) at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:1  
require at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:54  
require at org/jruby/RubyKernel.java:1040  
(root) at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/security.rb:11  
(root) at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:1  
require at org/jruby/RubyKernel.java:1040  
require at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:54  
(root) at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/package.rb:43  
require at org/jruby/RubyKernel.java:1040  
(root) at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:1  
require at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/core\_ext/kernel\_require.rb:54  
relk-a:/usr/share/logstash #

What am I missing? Some chunk of java or ruby that wasn't installed along with logstash? And if so, why not?

Hope to hear from you,

Randy in Seattle

---

<div class="post-metadata">

**Author:** ![rrue](https://avatars.discourse-cdn.com/v4/letter/r/bb73d2/32.png) [@rrue](https://discuss.elastic.co/u/rrue)\
**Post date:** [September 7, 2017, 3:51pm UTC](https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744/2 "2017-09-07T15:51:31Z")

</div>

OK, found a similar post from last September from a guy who upgraded to LS 2.4 and on launching got the exact same error. His fix was to upgrade java to 1.8.

But I'm already running java 1.8. It is the openjdk version, however:

relk-a:/usr/share/logstash # java -version  
openjdk version "1.8.0\_131"  
OpenJDK Runtime Environment (IcedTea 3.4.0) (suse-10.8.1-x86\_64)  
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)  
relk-a:/usr/share/logstash #

Do I need the "real" java? And why just for the plugin manager, not for logstash proper?

---

<div class="post-metadata">

**Author:** ![rrue](https://avatars.discourse-cdn.com/v4/letter/r/bb73d2/32.png) [@rrue](https://discuss.elastic.co/u/rrue)\
**Post date:** [September 7, 2017, 4:04pm UTC](https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744/3 "2017-09-07T16:04:33Z")

</div>

Proceeding on the assumption that openjdk is OK and I don't need the Oracle, as logstash itself is OK and I've never had to before (OK, once, to run minecraft on my kid's old laptop).

Installed the openssl and jruby-openssl gems (jruby-openssl also installed bouncy-castle-java). Still no love. "gem search" doesn't show anything that looks like "jopenssl," the bit that's named in the LoadError.

Going to stop flailing for a while and hope to hear from you.

- r

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [September 7, 2017, 4:10pm UTC](https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744/4 "2017-09-07T16:10:17Z")

</div>

It could be an issue related to libraries available on the system _this_ java was built on. It _says_ it's `1.8.0_131`, but it might be an incompatible library inside the build, which also specifically states: `suse-10.8.1-x86_64` (which I confess, I do not fully comprehend the meaning of nor implications of). Without knowing a lot of the specifics about the build system, that would be my first guess.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [September 7, 2017, 4:11pm UTC](https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744/5 "2017-09-07T16:11:59Z")

</div>

I point to [this entry](https://discuss.elastic.co/t/logstash-6-0-beta-1-cant-work-with-ibm-jre-8-due-to-old-jruby-openssl/98547) as an example of another case where a custom-built JRE wound up having a library conflict (at the JRuby level) that prevented Logstash from working on a particular system.

---

<div class="post-metadata">

**Author:** ![rrue](https://avatars.discourse-cdn.com/v4/letter/r/bb73d2/32.png) [@rrue](https://discuss.elastic.co/u/rrue)\
**Post date:** [September 7, 2017, 4:25pm UTC](https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744/6 "2017-09-07T16:25:51Z")

</div>

FWIW, I couldn't resist the urge to keep flailing and installed the Oracle RPM for 1.8.0\_131 (it's a snapshotted VM). Now it works.

Don't really want to put a different java on one build. Have to think about this.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 5, 2017, 4:38pm UTC](https://discuss.elastic.co/t/logstash-plugin-fails-with-java-errors-on-a-clean-install/99744/7 "2017-10-05T16:38:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
