# Logstash-plugin list throws an Gemfile error

**URL:** <https://discuss.elastic.co/t/logstash-plugin-list-throws-an-gemfile-error/133065>\
**Category:** Logstash\
**Created:** [May 24, 2018, 2:23am UTC](https://discuss.elastic.co/t/logstash-plugin-list-throws-an-gemfile-error/133065 "2018-05-24T02:23:09Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [May 24, 2018, 2:23am UTC](https://discuss.elastic.co/t/logstash-plugin-list-throws-an-gemfile-error/133065/1 "2018-05-24T02:23:10Z")

</div>

Hello,

I've just updated a logstash instance from 5.6 to 6.2.1 and now when I try to run `logstash-plugin list` I got the following error:

```auto
Gem::LoadError: You have already activated jruby-openssl 0.10.0, but your Gemfile requires jruby-openssl 0.9.21. Prepending `bundle exec` to your command may solve this.
  block in setup at /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/bundler-1.9.10/lib/bundler/runtime.rb:34
            each at org/jruby/RubyArray.java:1734
            each at /usr/share/logstash/vendor/jruby/lib/ruby/stdlib/forwardable.rb:189
           setup at /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/bundler-1.9.10/lib/bundler/runtime.rb:19
           setup at /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/bundler-1.9.10/lib/bundler.rb:122
          setup! at /usr/share/logstash/lib/bootstrap/bundler.rb:57
         execute at /usr/share/logstash/lib/pluginmanager/list.rb:17
             run at /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67
         execute at /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11
             run at /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67
             run at /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132
          <main> at /usr/share/logstash/lib/pluginmanager/main.rb:48

```

The `logstash-plugin install` works without any problem, I installed two plugins (filter-translate and x-pack).

Should I ran `logstash-plugin update`?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 21, 2018, 2:23am UTC](https://discuss.elastic.co/t/logstash-plugin-list-throws-an-gemfile-error/133065/2 "2018-06-21T02:23:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
