# Logstash port is not opening

**URL:** https://discuss.elastic.co/t/logstash-port-is-not-opening/221564
**Category:** Logstash
**Created:** [March 1, 2020, 12:11pm UTC](https://discuss.elastic.co/t/logstash-port-is-not-opening/221564 "2020-03-01T12:11:24Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![tbhaxor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tbhaxor/32/63588_2.png) [@tbhaxor](https://discuss.elastic.co/u/tbhaxor)
#### Post date: [March 1, 2020, 12:11pm UTC](https://discuss.elastic.co/t/logstash-port-is-not-opening/221564/1 "2020-03-01T12:11:24Z")

</div>

I have configured the logstash to bind `0.0.0.0:9600`, after giving logstash service some time, the output of `netstat -tunlpa | grep 9600` is empty

```auto
# journalctl -xe | grep logstash | tail -30
Mar 01 17:38:09 soc logstash[17986]: WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.9.0.jar) to method sun.nio.ch.NativeThread.signal(long)
Mar 01 17:38:09 soc logstash[17986]: WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules
Mar 01 17:38:09 soc logstash[17986]: WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
Mar 01 17:38:09 soc logstash[17986]: WARNING: All illegal access operations will be denied in a future release
Mar 01 17:38:29 soc logstash[17986]: Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
Mar 01 17:38:31 soc logstash[17986]: [2020-03-01T17:38:31,248][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.6.0"}
Mar 01 17:38:32 soc logstash[17986]: [2020-03-01T17:38:32,294][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=>"/etc/logstash/conf.d/*.conf"}
Mar 01 17:38:32 soc logstash[17986]: [2020-03-01T17:38:32,333][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
Mar 01 17:38:32 soc logstash[17986]: [2020-03-01T17:38:32,680][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
Mar 01 17:38:37 soc logstash[17986]: [2020-03-01T17:38:37,586][INFO][logstash.runner] Logstash shut down.
Mar 01 17:38:38 soc systemd[1]: logstash.service: Main process exited, code=exited, status=1/FAILURE
Mar 01 17:38:38 soc systemd[1]: logstash.service: Failed with result 'exit-code'.
Mar 01 17:38:38 soc systemd[1]: logstash.service: Service hold-off time over, scheduling restart.
Mar 01 17:38:38 soc systemd[1]: logstash.service: Scheduled restart job, restart counter is at 6.
-- Automatic restarting of the unit logstash.service has been scheduled, as the result for
Mar 01 17:38:38 soc systemd[1]: Stopped logstash.
-- Subject: Unit logstash.service has finished shutting down
-- Unit logstash.service has finished shutting down.
Mar 01 17:38:38 soc systemd[1]: Started logstash.
-- Subject: Unit logstash.service has finished start-up
-- Unit logstash.service has finished starting up.
Mar 01 17:38:38 soc logstash[18060]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Mar 01 17:38:40 soc logstash[18060]: WARNING: An illegal reflective access operation has occurred
Mar 01 17:38:40 soc logstash[18060]: WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.9.0.jar) to method sun.nio.ch.NativeThread.signal(long)
Mar 01 17:38:40 soc logstash[18060]: WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules
Mar 01 17:38:40 soc logstash[18060]: WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
Mar 01 17:38:40 soc logstash[18060]: WARNING: All illegal access operations will be denied in a future release
Mar 01 17:38:59 soc logstash[18060]: Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
Mar 01 17:39:00 soc logstash[18060]: [2020-03-01T17:39:00,245][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.6.0"}
Mar 01 17:39:01 soc logstash[18060]: [2020-03-01T17:39:01,218][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=>"/etc/logstash/conf.d/*.conf"}
Mar 01 17:39:01 soc logstash[18060]: [2020-03-01T17:39:01,280][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
Mar 01 17:39:01 soc logstash[18060]: [2020-03-01T17:39:01,569][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
Mar 01 17:39:06 soc logstash[18060]: [2020-03-01T17:39:06,463][INFO][logstash.runner] Logstash shut down.
Mar 01 17:39:06 soc systemd[1]: logstash.service: Main process exited, code=exited, status=1/FAILURE
Mar 01 17:39:06 soc systemd[1]: logstash.service: Failed with result 'exit-code'.
Mar 01 17:39:07 soc systemd[1]: logstash.service: Service hold-off time over, scheduling restart.
Mar 01 17:39:07 soc systemd[1]: logstash.service: Scheduled restart job, restart counter is at 7.
-- Automatic restarting of the unit logstash.service has been scheduled, as the result for
Mar 01 17:39:07 soc systemd[1]: Stopped logstash.
-- Subject: Unit logstash.service has finished shutting down
-- Unit logstash.service has finished shutting down.
Mar 01 17:39:07 soc systemd[1]: Started logstash.
-- Subject: Unit logstash.service has finished start-up
-- Unit logstash.service has finished starting up.
Mar 01 17:39:07 soc logstash[18142]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Mar 01 17:39:08 soc logstash[18142]: WARNING: An illegal reflective access operation has occurred
Mar 01 17:39:08 soc logstash[18142]: WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.9.0.jar) to method sun.nio.ch.NativeThread.signal(long)
Mar 01 17:39:08 soc logstash[18142]: WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules
Mar 01 17:39:08 soc logstash[18142]: WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
Mar 01 17:39:08 soc logstash[18142]: WARNING: All illegal access operations will be denied in a future release

```

---

<div class="post-metadata">

### Author: ![tatdat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tatdat/32/113160_2.png) [@tatdat](https://discuss.elastic.co/u/tatdat)
#### Post date: [March 1, 2020, 2:20pm UTC](https://discuss.elastic.co/t/logstash-port-is-not-opening/221564/2 "2020-03-01T14:20:43Z")

</div>

this is error

> No config files found in path {:path=\>"/etc/logstash/conf.d/\*.conf"}

---

<div class="post-metadata">

### Author: ![tbhaxor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tbhaxor/32/63588_2.png) [@tbhaxor](https://discuss.elastic.co/u/tbhaxor)
#### Post date: [March 1, 2020, 4:58pm UTC](https://discuss.elastic.co/t/logstash-port-is-not-opening/221564/3 "2020-03-01T16:58:10Z")

</div>

would you tell me where did you find the error?

---

<div class="post-metadata">

### Author: ![tatdat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tatdat/32/113160_2.png) [@tatdat](https://discuss.elastic.co/u/tatdat)
#### Post date: [March 2, 2020, 4:43am UTC](https://discuss.elastic.co/t/logstash-port-is-not-opening/221564/4 "2020-03-02T04:43:55Z")

</div>

Insight you logstash log, that you posted 😃

---

<div class="post-metadata">

### Author: ![tbhaxor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tbhaxor/32/63588_2.png) [@tbhaxor](https://discuss.elastic.co/u/tbhaxor)
#### Post date: [March 2, 2020, 5:58am UTC](https://discuss.elastic.co/t/logstash-port-is-not-opening/221564/5 "2020-03-02T05:58:28Z")

</div>

I am afraid it didn't help.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 30, 2020, 5:58am UTC](https://discuss.elastic.co/t/logstash-port-is-not-opening/221564/6 "2020-03-30T05:58:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
