# Logstash refuses to start when 3 or more rabbitmq outputs are used. (message=\>"The error reported is: \\n)

**URL:** <https://discuss.elastic.co/t/logstash-refuses-to-start-when-3-or-more-rabbitmq-outputs-are-used-message-the-error-reported-is-n/42415>\
**Category:** Logstash\
**Created:** [February 22, 2016, 6:15pm UTC](https://discuss.elastic.co/t/logstash-refuses-to-start-when-3-or-more-rabbitmq-outputs-are-used-message-the-error-reported-is-n/42415 "2016-02-22T18:15:47Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![utilitynerd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/utilitynerd/32/22944_2.png) [@utilitynerd](https://discuss.elastic.co/u/utilitynerd)\
**Post date:** [February 22, 2016, 6:15pm UTC](https://discuss.elastic.co/t/logstash-refuses-to-start-when-3-or-more-rabbitmq-outputs-are-used-message-the-error-reported-is-n/42415/1 "2016-02-22T18:15:48Z")

</div>

logstash 2.2.2  
logstash-output-rabbitmq (3.0.7)

After upgrading to logstash 2.2.0 and updating all plugins, my instance of logstash is refusing to start.

The logstash log only contains:  
{:timestamp=\>"2016-02-22T09:39:49.413000-0800", :message=\>"The error reported is: \n "}

Running config test yields:  
[root@bombay conf.d]# service logstash configtest  
The error reported is:

After spending some time debugging, I've tracked the issue back to the rabbitmq-output plugin. (The output section of my logstash configuration file is at the end of this post.)

My configuration has 4 separate rabbitmq outputs. Each of these outputs works on it's own (ie. I removed the other 3 rabbitmq outputs). I also tested every permutation using 2 out out 4 outputs and had no issues. However, as soon as I add a third rabbitmq output, I get the error messages above and am unable to start logstash.

logstash.conf output section

output {

if [alert\_source] == "u2json" {  
rabbitmq {  
exchange =\> 'snort\_events\_ex'  
exchange\_type =\> 'direct'  
host =\> '127.0.0.1'  
key =\> 'snort\_events'  
vhost =\> '/sock'  
user =\> 'logstash'  
password =\> 'sekret'  
}  
}

if [alert\_source] in ["snort","repsm"] or "udp\_syslog" in [tags] {  
rabbitmq {  
exchange =\> 'ids\_alerts\_ex'  
exchange\_type =\> 'direct'  
host =\> '127.0.0.1'  
key =\> 'ids\_alerts'  
vhost =\> '/sock'  
user =\> 'logstash'  
password =\> 'sekret'  
}  
}

if [dhcp\_source] == "standard" or [dhcp\_source] == "infoblox" {  
rabbitmq {  
exchange =\> 'dhcp\_logs\_ex'  
exchange\_type =\> 'direct'  
host =\> '127.0.0.1'  
key =\> 'dhcp\_logs'  
vhost =\> '/sock'  
user =\> 'logstash'  
password =\> 'sekret'  
}  
}

if "infoblox\_audit" in [tags] {  
rabbitmq {  
exchange =\> 'infoblox\_audit\_ex'  
exchange\_type =\> 'direct'  
host =\> '127.0.0.1'  
key =\> 'infoblox\_audit'  
vhost =\> '/sock'  
user =\> 'logstash'  
password =\> 'sekret'  
}  
}

}

---

<div class="post-metadata">

**Author:** ![utilitynerd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/utilitynerd/32/22944_2.png) [@utilitynerd](https://discuss.elastic.co/u/utilitynerd)\
**Post date:** [February 24, 2016, 5:12pm UTC](https://discuss.elastic.co/t/logstash-refuses-to-start-when-3-or-more-rabbitmq-outputs-are-used-message-the-error-reported-is-n/42415/2 "2016-02-24T17:12:31Z")

</div>

For anyone else running into this, there is an open github issue:

> <https://github.com/logstash-plugins/logstash-output-rabbitmq/issues/41>

---

<div class="post-metadata">

**Author:** ![marke72](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marke72/32/10832_2.png) [@marke72](https://discuss.elastic.co/u/marke72)\
**Post date:** [February 29, 2016, 5:31pm UTC](https://discuss.elastic.co/t/logstash-refuses-to-start-when-3-or-more-rabbitmq-outputs-are-used-message-the-error-reported-is-n/42415/3 "2016-02-29T17:31:51Z")

</div>

That's strange. I have 8 outputs to RabbitMQ from one server with no issue. Although, it might be because they are separated into 8 different configuration files. I've never tried having them in one. You could possibly try separating them. I don't think it matters that they are in the same file or not. It should still grab them based on your if statements. I remember messing up on an if statement for one of the 8 configurations and everything flooded into the single one as well as going to their individual outputs.

---

<div class="post-metadata">

**Author:** ![ebuildy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ebuildy/32/6070_2.png) [@ebuildy](https://discuss.elastic.co/u/ebuildy)\
**Post date:** [February 29, 2016, 5:39pm UTC](https://discuss.elastic.co/t/logstash-refuses-to-start-when-3-or-more-rabbitmq-outputs-are-used-message-the-error-reported-is-n/42415/4 "2016-02-29T17:39:46Z")

</div>

Could be the new pipeline / multi thread architecture, how many pipeline workers did you set?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:09am UTC](https://discuss.elastic.co/t/logstash-refuses-to-start-when-3-or-more-rabbitmq-outputs-are-used-message-the-error-reported-is-n/42415/5 "2017-07-06T05:09:17Z")

</div>


