# Logstash restart error?

**URL:** https://discuss.elastic.co/t/logstash-restart-error/42349
**Category:** Logstash
**Created:** [February 22, 2016, 2:33am UTC](https://discuss.elastic.co/t/logstash-restart-error/42349 "2016-02-22T02:33:17Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![clifford](https://avatars.discourse-cdn.com/v4/letter/c/e56c9b/32.png) [@clifford](https://discuss.elastic.co/u/clifford)
#### Post date: [February 22, 2016, 2:33am UTC](https://discuss.elastic.co/t/logstash-restart-error/42349/1 "2016-02-22T02:33:17Z")

</div>

My environment is logstash and elasticsearch with a single server.  
Last week I try to modify the logstash config file,`configtest result is ok`, and then restart the logstash service.But an error restart service results:`{:timestamp=>"2016-02-22T10:15:26.502000+0800", :message=>"The error reported is: \n Address already in use - bind - Address already in use"}`

I try to find the port 5044 and then kill off, but the lsof - I: 5044 result is empty.Netstat lanp | grep logstash as well.

I don't know what is the problem?!!!

---

<div class="post-metadata">

### Author: ![James\_Tang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/james_tang/32/8112_2.png) [@James\_Tang](https://discuss.elastic.co/u/James_Tang)
#### Post date: [February 22, 2016, 2:47am UTC](https://discuss.elastic.co/t/logstash-restart-error/42349/2 "2016-02-22T02:47:50Z")

</div>

There are 2 service here which is different and separate. Logstash and ElasticSearch.  
Logstash do not explicitly bind to a port. ElasticSearch does. If Both are down when u are restarting it then the issue should lie elsewhere.

Check the input section of the logstash config and see if any inputs is listening for input and then check it against the service of the machine it is running on. Perhaps that is causing the port in use error.

---

<div class="post-metadata">

### Author: ![James\_Tang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/james_tang/32/8112_2.png) [@James\_Tang](https://discuss.elastic.co/u/James_Tang)
#### Post date: [February 22, 2016, 2:49am UTC](https://discuss.elastic.co/t/logstash-restart-error/42349/3 "2016-02-22T02:49:04Z")

</div>

BTW they should be started seperately. With priority given to ES. First Up, Last down.

---

<div class="post-metadata">

### Author: ![clifford](https://avatars.discourse-cdn.com/v4/letter/c/e56c9b/32.png) [@clifford](https://discuss.elastic.co/u/clifford)
#### Post date: [February 22, 2016, 7:30am UTC](https://discuss.elastic.co/t/logstash-restart-error/42349/4 "2016-02-22T07:30:14Z")

</div>

thanks . i'am solved it. that's you say input section lessenning beats 5044 port 。

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 5:10am UTC](https://discuss.elastic.co/t/logstash-restart-error/42349/5 "2017-07-06T05:10:21Z")

</div>


