# Logstash RSS plugin failed to load after fresh install

**URL:** <https://discuss.elastic.co/t/logstash-rss-plugin-failed-to-load-after-fresh-install/345988>\
**Category:** Logstash\
**Created:** [October 29, 2023, 8:04pm UTC](https://discuss.elastic.co/t/logstash-rss-plugin-failed-to-load-after-fresh-install/345988 "2023-10-29T20:04:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![developerx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/developerx/32/126073_2.png) [@developerx](https://discuss.elastic.co/u/developerx)\
**Post date:** [October 29, 2023, 8:04pm UTC](https://discuss.elastic.co/t/logstash-rss-plugin-failed-to-load-after-fresh-install/345988/1 "2023-10-29T20:04:22Z")

</div>

Hello,

i've an issue with a fresh logstash installation and logstash-input-rss plugin. when trying to test the configuration for a simple RSS reader for just 1 URL i got this error:

[DEBUG] 2023-10-29 19:57:25.354 [Converge PipelineAction::Create] registry - Tried to load a plugin's code, but failed. {:exception=\>#\<LoadError: no such file to load -- rss\>, :path=\>"rss", :type=\>"input", :name=\>"rss"}  
[ERROR] 2023-10-29 19:57:25.397 [Converge PipelineAction::Create] registry - Unable to load plugin. {:type=\>"input", :name=\>"rss"}  
[DEBUG] 2023-10-29 19:57:25.398 [Converge PipelineAction::Create] registry - Problems loading the plugin with {:type=\>"input", :name=\>"rss"}  
[ERROR] 2023-10-29 19:57:25.403 [Converge PipelineAction::Create] agent - Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"Java::JavaLang::IllegalStateException", :message=\>"Unable to configure plugins: (PluginLoadingError) Couldn't find any input plugin named 'rss'. Are you sure this is correct? Trying to load the rss input plugin resulted in this error: Unable to load the requested plugin named rss of type input. The plugin is not installed."

i tried many times to understand what is the issue but I'm sure it was working in previous versions.

Is the new logstash version not comnpitable with the old rss-plugin version 3.0.5 ?

what is the issue and why the logstash can't load the plugin code ? can we fix this ?

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 30, 2023, 1:15am UTC](https://discuss.elastic.co/t/logstash-rss-plugin-failed-to-load-after-fresh-install/345988/2 "2023-10-30T01:15:30Z")

</div>

> [@developerx](#):
>
> what is the issue and why the logstash can't load the plugin code ? can we fix this ?

The logstash package does not bundle all the plugins that exist. It does not install rss by default. The documentation [covers](https://www.elastic.co/guide/en/logstash/8.10/working-with-plugins.html#installing-plugins) the simple procedure to fix this.

---

<div class="post-metadata">

**Author:** ![developerx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/developerx/32/126073_2.png) [@developerx](https://discuss.elastic.co/u/developerx)\
**Post date:** [October 30, 2023, 9:15am UTC](https://discuss.elastic.co/t/logstash-rss-plugin-failed-to-load-after-fresh-install/345988/3 "2023-10-30T09:15:35Z")

</div>

Thanks Badger for your response, I'm sorry that i didn't mention that i know how to install the plugin, and already i installed the plugin because i mentioned the version.  
So the plugin is installed with the latest version 3.0.5 and located here:  
`/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-input-rss-3.0.5`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 27, 2023, 9:16am UTC](https://discuss.elastic.co/t/logstash-rss-plugin-failed-to-load-after-fresh-install/345988/4 "2023-11-27T09:16:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
