# Logstash running and failing w/o apparent errors in logs on Docker/Fargate

**URL:** <https://discuss.elastic.co/t/logstash-running-and-failing-w-o-apparent-errors-in-logs-on-docker-fargate/202726>\
**Category:** Logstash\
**Tags:** docker\
**Created:** [October 8, 2019, 8:44pm UTC](https://discuss.elastic.co/t/logstash-running-and-failing-w-o-apparent-errors-in-logs-on-docker-fargate/202726 "2019-10-08T20:44:37Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![davewolf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davewolf/32/55500_2.png) [@davewolf](https://discuss.elastic.co/u/davewolf)\
**Post date:** [October 8, 2019, 8:44pm UTC](https://discuss.elastic.co/t/logstash-running-and-failing-w-o-apparent-errors-in-logs-on-docker-fargate/202726/1 "2019-10-08T20:44:37Z")

</div>

After resolving my previous errors the logstash application is starting successfully, connecting with Elasticsearch on Elastic Cloud, validating the licenses successfully, starting the pipelines, and metrics, and successfully running a healthcheck; then a sigterm is issued and the process is killed. I've set the logs to "debug" and have not found any issues.

The ECS Container Healthcheck runs successfully with a 200 response status code, then shortly thereafter, a sigterm is issued:

[2019-10-08T22:13:18,844][DEBUG][logstash.agent] API HTTP Request {:status=\>200, :request\_method=\>"GET", :path\_info=\>"/", :query\_string=\>"pretty", :http\_version=\>"HTTP/1.1", :http\_accept=\>"_/_"}

[2019-10-08T22:13:20,141][DEBUG][org.logstash.execution.PeriodicFlush] Pushing flush onto pipeline.

[2019-10-08T22:13:20,449][DEBUG][logstash.agent] Converging pipelines state {:actions\_count=\>0}

[2019-10-08T22:13:20,588][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ParNew"}

[2019-10-08T22:13:20,588][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ConcurrentMarkSweep"}

[2019-10-08T22:13:25,141][DEBUG][org.logstash.execution.PeriodicFlush] Pushing flush onto pipeline.

[2019-10-08T22:13:25,455][DEBUG][logstash.agent] Converging pipelines state {:actions\_count=\>0}

[2019-10-08T22:13:25,593][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ParNew"}

[2019-10-08T22:13:25,593][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ConcurrentMarkSweep"}

[2019-10-08T22:13:30,141][DEBUG][org.logstash.execution.PeriodicFlush] Pushing flush onto pipeline.

[2019-10-08T22:13:30,444][DEBUG][logstash.agent] Converging pipelines state {:actions\_count=\>0}

[2019-10-08T22:13:30,599][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ParNew"}

[2019-10-08T22:13:30,600][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ConcurrentMarkSweep"}

[2019-10-08T22:13:35,141][DEBUG][org.logstash.execution.PeriodicFlush] Pushing flush onto pipeline.

[2019-10-08T22:13:35,443][DEBUG][logstash.agent] Converging pipelines state {:actions\_count=\>0}

[2019-10-08T22:13:35,605][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ParNew"}

[2019-10-08T22:13:35,605][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ConcurrentMarkSweep"}

[2019-10-08T22:13:40,141][DEBUG][org.logstash.execution.PeriodicFlush] Pushing flush onto pipeline.

[2019-10-08T22:13:40,444][DEBUG][logstash.agent] Converging pipelines state {:actions\_count=\>0}

[2019-10-08T22:13:40,610][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ParNew"}

[2019-10-08T22:13:40,610][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ConcurrentMarkSweep"}

[2019-10-08T22:13:42,030][WARN][logstash.runner] SIGTERM received. Shutting down.

# logstash.yml

node.name: Fargate-Logstash

cloud.id:   
cloud.auth: logstash\_admin\_user:${logstash\_admin}

http.host: "0.0.0.0"  
http.port: 9600  
log.level: debug  
xpack.monitoring.enabled: true  
xpack.monitoring.elasticsearch.hosts: ["Elasticsearch host URL on Elastic Cloud"]  
xpack.monitoring.elasticsearch.username: logstash\_application\_user  
xpack.monitoring.elasticsearch.password: ${es\_password}

xpack.management.enabled: true  
xpack.management.pipeline.id: ["rawlogs", ".monitoring-logstash"]  
xpack.management.elasticsearch.hosts: ["Elasticsearch host URL on Elastic Cloud"]  
xpack.management.elasticsearch.username: logstash\_admin\_user  
xpack.management.elasticsearch.password: ${logstash\_admin}

---

<div class="post-metadata">

**Author:** ![davewolf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davewolf/32/55500_2.png) [@davewolf](https://discuss.elastic.co/u/davewolf)\
**Post date:** [October 8, 2019, 11:24pm UTC](https://discuss.elastic.co/t/logstash-running-and-failing-w-o-apparent-errors-in-logs-on-docker-fargate/202726/2 "2019-10-08T23:24:36Z")

</div>

Ugh, I found the problem, it was a misconfiguration in AWS.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 5, 2019, 11:24pm UTC](https://discuss.elastic.co/t/logstash-running-and-failing-w-o-apparent-errors-in-logs-on-docker-fargate/202726/3 "2019-11-05T23:24:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
