# Logstash server running Salesforce-plugin

**URL:** <https://discuss.elastic.co/t/logstash-server-running-salesforce-plugin/229360>\
**Category:** Logstash\
**Created:** [April 22, 2020, 10:19pm UTC](https://discuss.elastic.co/t/logstash-server-running-salesforce-plugin/229360 "2020-04-22T22:19:03Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![eemtzc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eemtzc/32/54095_2.png) [@eemtzc](https://discuss.elastic.co/u/eemtzc)\
**Post date:** [April 22, 2020, 10:19pm UTC](https://discuss.elastic.co/t/logstash-server-running-salesforce-plugin/229360/1 "2020-04-22T22:19:04Z")

</div>

Hello,  
I have a logstash server specifically to run salesforce-plugin to update a pipeline. Everything "works" good except for the fact that recently found out that the logstash service on this server restarts every 12-20 minutes on avg.  
I have not been able to found any error on the logs or any misconfiguration, for some reason I found out this service was restarting.  
I was wonder if the salesforce-plugin for some reason restart this service at a certain point due to some parameter I am not aware of or this is a problem I have to solve with logstash? any help will very much appreciate it.

---

<div class="post-metadata">

**Author:** ![hlogan](https://avatars.discourse-cdn.com/v4/letter/h/7bcc69/32.png) [@hlogan](https://discuss.elastic.co/u/hlogan)\
**Post date:** [May 1, 2020, 5:55pm UTC](https://discuss.elastic.co/t/logstash-server-running-salesforce-plugin/229360/2 "2020-05-01T17:55:15Z")

</div>

Hi, Your using logstash-7.6.1? your salesforce plugin installed and able to start the conf successfully?I am having issue in starting plugin

---

<div class="post-metadata">

**Author:** ![Luca\_Belluccini](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/luca_belluccini/32/33239_2.png) [@Luca\_Belluccini](https://discuss.elastic.co/u/Luca_Belluccini)\
**Post date:** [May 1, 2020, 6:02pm UTC](https://discuss.elastic.co/t/logstash-server-running-salesforce-plugin/229360/3 "2020-05-01T18:02:28Z")

</div>

Please try to enable the debug logs on Logstash and observe if it occurs again.

We might capture additional information.

---

<div class="post-metadata">

**Author:** ![hlogan](https://avatars.discourse-cdn.com/v4/letter/h/7bcc69/32.png) [@hlogan](https://discuss.elastic.co/u/hlogan)\
**Post date:** [May 5, 2020, 3:50pm UTC](https://discuss.elastic.co/t/logstash-server-running-salesforce-plugin/229360/4 "2020-05-05T15:50:35Z")

</div>

@Luca_Belluccini .  
Here is the error message while starting the salesforce plugin

/logstash --path.settings /etc/logstash -f /etc/logstash/conf.d/demo-metrics-pipeline.conf  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.9.0.jar) to method sun.nio.ch.NativeThread.signal(long)  
WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties  
[2020-05-05T10:48:01,210][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2020-05-05T10:48:01,322][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.6.2"}  
[2020-05-05T10:48:03,457][INFO][org.reflections.Reflections] Reflections took 43 ms to scan 1 urls, producing 20 keys and 40 values  
[2020-05-05T10:48:03,585][ERROR][logstash.plugins.registry] Tried to load a plugin's code, but failed. {:exception=\>#\<LoadError: no such file to load -- logstash/inputs/salesforce\>, :path=\>"logstash/inputs/salesforce", :type=\>"input", :name=\>"salesforce"}  
[2020-05-05T10:48:03,601][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"Java::JavaLang::IllegalStateException", :message=\>"Unable to configure plugins: (PluginLoadingError) Couldn't find any input plugin named 'salesforce'. Are you sure this is correct? Trying to load the salesforce input plugin resulted in this error: no such file to load -- logstash/inputs/salesforce", :backtrace=\>["org.logstash.config.ir.CompiledPipeline.(CompiledPipeline.java:103)", "org.logstash.execution.JavaBasePipelineExt.initialize(JavaBasePipelineExt.java:60)", "org.logstash.execution.JavaBasePipelineExt$INVOKER$i$1$0$initialize.call(JavaBasePipelineExt$INVOKER$i$1$0$initialize.gen)", "org.jruby.internal.runtime.methods.JavaMethod$JavaMethodN.call(JavaMethod.java:837)", "org.jruby.ir.runtime.IRRuntimeHelpers.instanceSuper(IRRuntimeHelpers.java:1169)", "org.jruby.ir.runtime.IRRuntimeHelpers.instanceSuperSplatArgs(IRRuntimeHelpers.java:1156)", "org.jruby.ir.targets.InstanceSuperInvokeSite.invoke(InstanceSuperInvokeSite.java:39)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.RUBY$method$initialize$0(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:27)", "org.jruby.internal.runtime.methods.CompiledIRMethod.call(CompiledIRMethod.java:84)", "org.jruby.internal.runtime.methods.MixedModeIRMethod.call(MixedModeIRMethod.java:70)", "org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:332)", "org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:86)", "org.jruby.RubyClass.newInstance(RubyClass.java:915)", "org.jruby.RubyClass$INVOKER$i$newInstance.call(RubyClass$INVOKER$i$newInstance.gen)", "org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:183)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline\_action.create.RUBY$method$execute$0(/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:36)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.pipeline\_action.create.RUBY$method$execute$0$ **VARARGS** (/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb)", "org.jruby.internal.runtime.methods.CompiledIRMethod.call(CompiledIRMethod.java:84)", "org.jruby.internal.runtime.methods.MixedModeIRMethod.call(MixedModeIRMethod.java:70)", "org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:183)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.agent.RUBY$block$converge\_state$2(/usr/share/logstash/logstash-core/lib/logstash/agent.rb:326)", "org.jruby.runtime.CompiledIRBlockBody.callDirect(CompiledIRBlockBody.java:136)", "org.jruby.runtime.IRBlockBody.call(IRBlockBody.java:77)", "org.jruby.runtime.IRBlockBody.call(IRBlockBody.java:71)", "org.jruby.runtime.Block.call(Block.java:125)", "org.jruby.RubyProc.call(RubyProc.java:274)", "org.jruby.internal.runtime.RubyRunnable.run(RubyRunnable.java:105)", "java.base/java.lang.Thread.run(Thread.java:834)"]}  
warning: thread "Converge PipelineAction::Create" terminated with exception (report\_on\_exception is true):  
LogStash::Error: Don't know how to handle `Java::JavaLang::IllegalStateException` for `PipelineAction::Create<main>`  
create at org/logstash/execution/ConvergeResultExt.java:109  
add at org/logstash/execution/ConvergeResultExt.java:37  
converge\_state at /usr/share/logstash/logstash-core/lib/logstash/agent.rb:339  
[2020-05-05T10:48:03,617][ERROR][logstash.agent] An exception happened when converging configuration {:exception=\>LogStash::Error, :message=\>"Don't know how to handle `Java::JavaLang::IllegalStateException` for `PipelineAction::Create<main>`", :backtrace=\>["org/logstash/execution/ConvergeResultExt.java:109:in `create'", "org/logstash/execution/ConvergeResultExt.java:37:in `add'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:339:in `block in converge_state'"]} [2020-05-05T10:48:03,687][FATAL][logstash.runner] An unexpected error occurred! {:error=>#<LogStash::Error: Don't know how to handle `Java::JavaLang::IllegalStateException`for`PipelineAction::Create`>, :backtrace=>["org/logstash/execution/ConvergeResultExt.java:109:in `create'", "org/logstash/execution/ConvergeResultExt.java:37:in `add'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:339:in `block in converge\_state'"]}  
[2020-05-05T10:48:03,713][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

---

<div class="post-metadata">

**Author:** ![Luca\_Belluccini](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/luca_belluccini/32/33239_2.png) [@Luca\_Belluccini](https://discuss.elastic.co/u/Luca_Belluccini)\
**Post date:** [May 5, 2020, 6:20pm UTC](https://discuss.elastic.co/t/logstash-server-running-salesforce-plugin/229360/5 "2020-05-05T18:20:37Z")

</div>

There seems to be a known issue at [https://github.com/logstash-plugins/logstash-input-salesforce/issues/21](https://github.com/logstash-plugins/logstash-input-salesforce/issues/21)

I'll try to take a look at it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 2, 2020, 6:25pm UTC](https://discuss.elastic.co/t/logstash-server-running-salesforce-plugin/229360/6 "2020-06-02T18:25:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
