# Logstash service failure ''Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError"

**URL:** <https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728>\
**Category:** Logstash\
**Created:** [May 15, 2020, 12:29am UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728 "2020-05-15T00:29:39Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![soufiane\_adn](https://avatars.discourse-cdn.com/v4/letter/s/e274bd/32.png) [@soufiane\_adn](https://discuss.elastic.co/u/soufiane_adn)\
**Post date:** [May 15, 2020, 12:29am UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/1 "2020-05-15T00:29:40Z")

</div>

Hello,  
im trying to run logstash as service by systemctl start logstash but i found the following error on log file  
[2020-05-15T00:12:10,751][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of [\t\r\n], "#", "input", "filter", "output" at line 6, column 1 (byte 132) after ", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:49:in `compile\_graph'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2580:in `map'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:161:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:47:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:27:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:36:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:326:in `block in converge\_state'"]}

but when i run it with /usr/share/logstash/bin/logstash --path.settings /etc/logstash -f /etc/logstash/conf.d/02-input-beats it works  
i don't know the source of the problem and i need your help  
thank in the advance

additional information:  
pipelines.yml:  
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

- pipeline.id: beats-input  
queue.type: persisted  
path.config: "/etc/logstash/conf.d/02-input-beats.conf"  
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''  
and the file 02-input-beats  
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''  
input {  
beats { port =\> 5044 }  
}  
output {  
elasticsearch {  
hosts =\> ["[https://10.10.2.1:9200](https://10.10.2.1:9200)"]  
ssl\_certificate\_verification =\> "true"  
cacert =\> '/etc/logstash/certs/ca/ca.crt'  
manage\_template =\> false  
index =\> "winlogbeat-test"  
user =\> logstash\_internal  
password =\> \*\*\*\*\*\*  
}  
}  
'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

thanks again

---

<div class="post-metadata">

**Author:** ![ptamba](https://avatars.discourse-cdn.com/v4/letter/p/7feea3/32.png) [@ptamba](https://discuss.elastic.co/u/ptamba)\
**Post date:** [May 15, 2020, 2:37am UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/2 "2020-05-15T02:37:15Z")

</div>

i believe by default logstash will use /etc/logstash as path.settings in systemd based system. can you share the content of `/etc/systemd/system/logstash.service` and `/etc/default/logstash` ?

---

<div class="post-metadata">

**Author:** ![soufiane\_adn](https://avatars.discourse-cdn.com/v4/letter/s/e274bd/32.png) [@soufiane\_adn](https://discuss.elastic.co/u/soufiane_adn)\
**Post date:** [May 15, 2020, 9:57am UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/3 "2020-05-15T09:57:59Z")

</div>

hello,  
thanks for your response finds below the content of files  
and btw i changed the user and group to root because i had a problem of logsatsh permission denied

'''''''''''''''''''''''''''''''''''''''''''''''' `/etc/systemd/system/logstash.service`''''''''''''''''''''''''''''''''''''  
[Unit]  
Description=logstash

[Service]  
Type=simple  
User=root  
Group=root

# Load env vars from /etc/default/ and /etc/sysconfig/ if they exist.

# Prefixing the path with '-' makes it try to load, but if the file doesn't

# exist, it continues onward.

EnvironmentFile=-/etc/default/logstash  
EnvironmentFile=-/etc/sysconfig/logstash  
ExecStart=/usr/share/logstash/bin/logstash "--path.settings" "/etc/logstash"  
Restart=always  
WorkingDirectory=/  
Nice=19  
LimitNOFILE=16384

[Install]  
WantedBy=multi-user.target  
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''  
/etc/default/logstash  
LS\_HOME="/usr/share/logstash"  
LS\_SETTINGS\_DIR="/etc/logstash"  
LS\_PIDFILE="/var/run/logstash.pid"  
LS\_USER="logstash"  
LS\_GROUP="logstash"  
LS\_GC\_LOG\_FILE="/var/log/logstash/gc.log"  
LS\_OPEN\_FILES="16384"  
LS\_NICE="19"  
SERVICE\_NAME="logstash"  
SERVICE\_DESCRIPTION="logstash"  
'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''  
thanks

---

<div class="post-metadata">

**Author:** ![ptamba](https://avatars.discourse-cdn.com/v4/letter/p/7feea3/32.png) [@ptamba](https://discuss.elastic.co/u/ptamba)\
**Post date:** [May 15, 2020, 11:16am UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/4 "2020-05-15T11:16:49Z")

</div>

you should fix the permission issue rather than running logstash as root. however, i couldn’t find anything strange in your service config. do you happen to have path.config or path.setting in logstash.yml? logstash define main pipeline by default, and looks like your pipelines.yml is ignored because it doesn’t contain pipeline id “main” that your error refers to.

check logstash.yml to see if you have path.config uncommented.

---

<div class="post-metadata">

**Author:** ![soufiane\_adn](https://avatars.discourse-cdn.com/v4/letter/s/e274bd/32.png) [@soufiane\_adn](https://discuss.elastic.co/u/soufiane_adn)\
**Post date:** [May 15, 2020, 11:46am UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/5 "2020-05-15T11:46:57Z")

</div>

i checked the logstash.yml and the path.config is uncommented  
and the problem persist

---

<div class="post-metadata">

**Author:** ![ptamba](https://avatars.discourse-cdn.com/v4/letter/p/7feea3/32.png) [@ptamba](https://discuss.elastic.co/u/ptamba)\
**Post date:** [May 15, 2020, 11:53am UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/6 "2020-05-15T11:53:49Z")

</div>

can you show your logstash.yml?

---

<div class="post-metadata">

**Author:** ![soufiane\_adn](https://avatars.discourse-cdn.com/v4/letter/s/e274bd/32.png) [@soufiane\_adn](https://discuss.elastic.co/u/soufiane_adn)\
**Post date:** [May 15, 2020, 12:09pm UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/7 "2020-05-15T12:09:54Z")

</div>

# Settings file in YAML

# 

# Settings can be specified either in hierarchical form, e.g.:

# 

# pipeline:

# batch:

# size: 125

# delay: 5

# 

# Or as flat keys:

# 

# pipeline.batch.size: 125

# pipeline.batch.delay: 5

# 

# ------------ Node identity ------------

# 

# Use a descriptive name for the node:

# 

# node.name: test

# 

# If omitted the node name will default to the machine's host name

# 

# ------------ Data path ------------------

# 

# Which directory should be used by logstash and its plugins

# for any persistent needs. Defaults to LOGSTASH\_HOME/data

# 

path.data: /var/lib/logstash

# 

# ------------ Pipeline Settings --------------

# 

# The ID of the pipeline.

# 

# pipeline.id: main

# 

# Set the number of workers that will, in parallel, execute the filters+outputs

# stage of the pipeline.

# 

# This defaults to the number of the host's CPU cores.

# 

# pipeline.workers: 2

# 

# How many events to retrieve from inputs before sending to filters+workers

# 

# pipeline.batch.size: 125

# 

# How long to wait in milliseconds while polling for the next event

# before dispatching an undersized batch to filters+outputs

# 

# pipeline.batch.delay: 50

# 

# Force Logstash to exit during shutdown even if there are still inflight

# events in memory. By default, logstash will refuse to quit until all

# received events have been pushed to the outputs.

# 

# WARNING: enabling this can lead to data loss during shutdown

# 

# pipeline.unsafe\_shutdown: false

# 

# Set the pipeline event ordering. Options are "auto" (the default), "true" or "false".

# "auto" will automatically enable ordering if the 'pipeline.workers' setting

# is also set to '1'.

# "true" will enforce ordering on the pipeline and prevent logstash from starting

# if there are multiple workers.

# "false" will disable any extra processing necessary for preserving ordering.

# 

pipeline.ordered: auto

# 

# ------------ Pipeline Configuration Settings --------------

# 

# Where to fetch the pipeline configuration for the main pipeline

# 

path.config: /etc/logstash

# 

# Pipeline configuration string for the main pipeline

# 

# config.string:

# 

# At startup, test if the configuration is valid and exit (dry run)

# 

# config.test\_and\_exit: false

# 

# Periodically check if the configuration has changed and reload the pipeline

# This can also be triggered manually through the SIGHUP signal

# 

# config.reload.automatic: false

# 

# How often to check if the pipeline configuration has changed (in seconds)

# Note that the unit value (s) is required. Values without a qualifier (e.g. 60)

# are treated as nanoseconds.

# Setting the interval this way is not recommended and might change in later versions.

# 

# config.reload.interval: 3s

# 

# Show fully compiled configuration as debug log message

# NOTE: --log.level must be 'debug'

# 

# config.debug: false

# 

# When enabled, process escaped characters such as \n and " in strings in the

# pipeline configuration files.

# 

# config.support\_escapes: false

# 

# ------------ Module Settings ---------------

# Define modules here. Modules definitions must be defined as an array.

# The simple way to see this is to prepend each `name` with a `-`, and keep

# all associated variables under the `name` they are associated with, and

# above the next, like this:

# 

# modules:

# - name: MODULE\_NAME

# var.PLUGINTYPE1.PLUGINNAME1.KEY1: VALUE

# var.PLUGINTYPE1.PLUGINNAME1.KEY2: VALUE

# var.PLUGINTYPE2.PLUGINNAME1.KEY1: VALUE

# var.PLUGINTYPE3.PLUGINNAME3.KEY1: VALUE

# 

# Module variable names must be in the format of

# 

# var.PLUGIN\_TYPE.PLUGIN\_NAME.KEY

# 

# modules:

# 

# ------------ Cloud Settings ---------------

# Define Elastic Cloud settings here.

# Format of cloud.id is a base64 value e.g. dXMtZWFzdC0xLmF3cy5mb3VuZC5pbyRub3RhcmVhbCRpZGVudGlmaWVy

# and it may have an label prefix e.g. staging:dXMtZ...

# This will overwrite 'var.elasticsearch.hosts' and 'var.kibana.host'

# cloud.id:

# 

# Format of cloud.auth is: :

# This is optional

# If supplied this will overwrite 'var.elasticsearch.username' and 'var.elasticsearch.password'

# If supplied this will overwrite 'var.kibana.username' and 'var.kibana.password'

# cloud.auth: elastic:

# 

# ------------ Queuing Settings --------------

# 

# Internal queuing model, "memory" for legacy in-memory based queuing and

# "persisted" for disk-based acked queueing. Defaults is memory

# 

# queue.type: memory

# 

# If using queue.type: persisted, the directory path where the data files will be stored.

# Default is path.data/queue

# 

# path.queue:

# 

# If using queue.type: persisted, the page data files size. The queue data consists of

# append-only data files separated into pages. Default is 64mb

# 

# queue.page\_capacity: 64mb

# 

# If using queue.type: persisted, the maximum number of unread events in the queue.

# Default is 0 (unlimited)

# 

# queue.max\_events: 0

# 

# If using queue.type: persisted, the total capacity of the queue in number of bytes.

# If you would like more unacked events to be buffered in Logstash, you can increase the

# capacity using this setting. Please make sure your disk drive has capacity greater than

# the size specified here. If both max\_bytes and max\_events are specified, Logstash will pick

# whichever criteria is reached first

# Default is 1024mb or 1gb

# 

# queue.max\_bytes: 1024mb

# 

# If using queue.type: persisted, the maximum number of acked events before forcing a checkpoint

# Default is 1024, 0 for unlimited

# 

# queue.checkpoint.acks: 1024

# 

# If using queue.type: persisted, the maximum number of written events before forcing a checkpoint

# Default is 1024, 0 for unlimited

# 

# queue.checkpoint.writes: 1024

# 

# If using queue.type: persisted, the interval in milliseconds when a checkpoint is forced on the head page

# Default is 1000, 0 for no periodic checkpoint.

# 

# queue.checkpoint.interval: 1000

# 

# ------------ Dead-Letter Queue Settings --------------

# Flag to turn on dead-letter queue.

# 

# dead\_letter\_queue.enable: false

# If using dead\_letter\_queue.enable: true, the maximum size of each dead letter queue. Entries

# will be dropped if they would increase the size of the dead letter queue beyond this setting.

# Default is 1024mb

# dead\_letter\_queue.max\_bytes: 1024mb

# If using dead\_letter\_queue.enable: true, the directory path where the data files will be stored.

# Default is path.data/dead\_letter\_queue

# 

# path.dead\_letter\_queue:

# 

# ------------ Metrics Settings --------------

# 

# Bind address for the metrics REST endpoint

# 

# http.host: "127.0.0.1"

# 

# Bind port for the metrics REST endpoint, this option also accept a range

# (9600-9700) and logstash will pick up the first available ports.

# 

# http.port: 9600-9700

# 

# ------------ Debugging Settings --------------

# 

# Options for log.level:

# \* fatal

# \* error

# \* warn

# \* info (default)

# \* debug

# \* trace

# 

# log.level: info

path.logs: /var/log/logstash

# 

# ------------ Other Settings --------------

# 

# Where to find custom plugins

# path.plugins:

# 

# Flag to output log lines of each pipeline in its separate log file. Each log filename contains the pipeline.name

# Default is false

# pipeline.separate\_logs: false

# 

# ------------ X-Pack Settings (not applicable for OSS build)--------------

# 

# X-Pack Monitoring

# [https://www.elastic.co/guide/en/logstash/current/monitoring-logstash.html](https://www.elastic.co/guide/en/logstash/current/monitoring-logstash.html)

#xpack.monitoring.enabled: false  
#xpack.monitoring.elasticsearch.username: logstash\_system  
#xpack.monitoring.elasticsearch.password: password  
#xpack.monitoring.elasticsearch.hosts: ["[https://es1:9200](https://es1:9200)", "[https://es2:9200](https://es2:9200)"]

# an alternative to hosts + username/password settings is to use cloud\_id/cloud\_auth

#xpack.monitoring.elasticsearch.cloud\_id: monitoring\_cluster\_id:xxxxxxxxxx  
#xpack.monitoring.elasticsearch.cloud\_auth: logstash\_system:password  
#xpack.monitoring.elasticsearch.ssl.certificate\_authority: ["/path/to/ca.crt"]  
#xpack.monitoring.elasticsearch.ssl.truststore.path: path/to/file  
#xpack.monitoring.elasticsearch.ssl.truststore.password: password  
#xpack.monitoring.elasticsearch.ssl.keystore.path: /path/to/file  
#xpack.monitoring.elasticsearch.ssl.keystore.password: password  
#xpack.monitoring.elasticsearch.ssl.verification\_mode: certificate  
#xpack.monitoring.elasticsearch.sniffing: false  
#xpack.monitoring.collection.interval: 10s  
#xpack.monitoring.collection.pipeline.details.enabled: true

# 

# X-Pack Management

# [https://www.elastic.co/guide/en/logstash/current/logstash-centralized-pipeline-management.html](https://www.elastic.co/guide/en/logstash/current/logstash-centralized-pipeline-management.html)

#xpack.management.enabled: false  
#xpack.management.pipeline.id: ["main", "apache\_logs"]  
#xpack.management.elasticsearch.username: logstash\_admin\_user  
#xpack.management.elasticsearch.password: password  
#xpack.management.elasticsearch.hosts: ["[https://es1:9200](https://es1:9200)", "[https://es2:9200](https://es2:9200)"]

# an alternative to hosts + username/password settings is to use cloud\_id/cloud\_auth

#xpack.management.elasticsearch.cloud\_id: management\_cluster\_id:xxxxxxxxxx  
#xpack.management.elasticsearch.cloud\_auth: logstash\_admin\_user:password  
#xpack.management.elasticsearch.ssl.certificate\_authority: ["/path/to/ca.crt"]  
#xpack.management.elasticsearch.ssl.truststore.path: /path/to/file  
#xpack.management.elasticsearch.ssl.truststore.password: password  
#xpack.management.elasticsearch.ssl.keystore.path: /path/to/file  
#xpack.management.elasticsearch.ssl.keystore.password: password  
#xpack.management.elasticsearch.ssl.verification\_mode: certificate  
#xpack.management.elasticsearch.sniffing: false  
#xpack.management.logstash.poll\_interval: 5s  
xpack.monitoring.enabled: true  
xpack.monitoring.elasticsearch.username: logstash\_system  
xpack.monitoring.elasticsearch.password: RTYUIO77  
xpack.monitoring.elasticsearch.hosts: ["[https://localhost:9200](https://localhost:9200)"]  
xpack.monitoring.elasticsearch.ssl.certificate\_authority: /etc/logstash/certs/ca/ca.crt  
xpack.monitoring.elasticsearch.ssl.verification\_mode: none

---

<div class="post-metadata">

**Author:** ![ptamba](https://avatars.discourse-cdn.com/v4/letter/p/7feea3/32.png) [@ptamba](https://discuss.elastic.co/u/ptamba)\
**Post date:** [May 15, 2020, 12:16pm UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/8 "2020-05-15T12:16:40Z")

</div>

please use markdown when you post configuration. it’s hard to see which are being commented and which aren’t

wrap config with ```

---

<div class="post-metadata">

**Author:** ![soufiane\_adn](https://avatars.discourse-cdn.com/v4/letter/s/e274bd/32.png) [@soufiane\_adn](https://discuss.elastic.co/u/soufiane_adn)\
**Post date:** [May 15, 2020, 12:29pm UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/9 "2020-05-15T12:29:07Z")

</div>

i tried to post it in markdown, if not here the uncommented line on my logstash.yml by order

######################################  
path.data: /var/lib/logstash  
pipeline.ordered: auto  
path.config: /etc/logstash  
path.logs: /var/log/logstash  
xpack.monitoring.enabled: true  
xpack.monitoring.elasticsearch.username: logstash\_system  
xpack.monitoring.elasticsearch.password: RTYUIO77  
xpack.monitoring.elasticsearch.hosts: ["[https://localhost:9200](https://localhost:9200)"]  
xpack.monitoring.elasticsearch.ssl.certificate\_authority: /etc/logstash/certs/ca/ca.crt  
xpack.monitoring.elasticsearch.ssl.verification\_mode: none  
############################################

---

<div class="post-metadata">

**Author:** ![ptamba](https://avatars.discourse-cdn.com/v4/letter/p/7feea3/32.png) [@ptamba](https://discuss.elastic.co/u/ptamba)\
**Post date:** [May 15, 2020, 1:11pm UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/10 "2020-05-15T13:11:38Z")

</div>

> [@soufiane\_adn](#):
>
> path.config: /etc/logstash

comment this line and try again

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 12, 2020, 1:11pm UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728/11 "2020-06-12T13:11:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
