# Logstash service is not running

**URL:** <https://discuss.elastic.co/t/logstash-service-is-not-running/106499>\
**Category:** Logstash\
**Created:** [November 6, 2017, 9:49am UTC](https://discuss.elastic.co/t/logstash-service-is-not-running/106499 "2017-11-06T09:49:42Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![enes](https://avatars.discourse-cdn.com/v4/letter/e/e36b37/32.png) [@enes](https://discuss.elastic.co/u/enes)\
**Post date:** [November 6, 2017, 9:49am UTC](https://discuss.elastic.co/t/logstash-service-is-not-running/106499/1 "2017-11-06T09:49:42Z")

</div>

Hi,  
I started to setup ELK. Elastic Search is ok. The problem on the logstash. when I started Logstash service got this error.  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/0/5/05df657cfbefd2b1e2fc5f1492d3d21ec5baa1e1.png)  
In the event log, I see this error details.

 ![error2](https://us1.discourse-cdn.com/elastic/original/3X/8/a/8a1f6594b6867f7fdaaa934d4f44da1537affa42.png)

The directory is valid on my computer.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 7, 2017, 12:25am UTC](https://discuss.elastic.co/t/logstash-service-is-not-running/106499/2 "2017-11-07T00:25:39Z")

</div>

FYI we’ve renamed ELK to the Elastic Stack, otherwise Beats and APM feel left out! 😉

Is there something in the Logstash logs?

---

<div class="post-metadata">

**Author:** ![enes](https://avatars.discourse-cdn.com/v4/letter/e/e36b37/32.png) [@enes](https://discuss.elastic.co/u/enes)\
**Post date:** [November 7, 2017, 6:13am UTC](https://discuss.elastic.co/t/logstash-service-is-not-running/106499/3 "2017-11-07T06:13:30Z")

</div>

Hi,  
I solved this problem by reinstall logstash and kibana windows service.  
Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 5, 2017, 6:13am UTC](https://discuss.elastic.co/t/logstash-service-is-not-running/106499/4 "2017-12-05T06:13:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
