# Logstash Service starts but it could not work without manually starting with --path.settings and -f parameters

**URL:** <https://discuss.elastic.co/t/logstash-service-starts-but-it-could-not-work-without-manually-starting-with-path-settings-and-f-parameters/200981>\
**Category:** Logstash\
**Created:** [September 25, 2019, 7:38am UTC](https://discuss.elastic.co/t/logstash-service-starts-but-it-could-not-work-without-manually-starting-with-path-settings-and-f-parameters/200981 "2019-09-25T07:38:09Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![alperensoydan](https://avatars.discourse-cdn.com/v4/letter/a/b3f665/32.png) [@alperensoydan](https://discuss.elastic.co/u/alperensoydan)\
**Post date:** [September 25, 2019, 7:38am UTC](https://discuss.elastic.co/t/logstash-service-starts-but-it-could-not-work-without-manually-starting-with-path-settings-and-f-parameters/200981/1 "2019-09-25T07:38:09Z")

</div>

Hello,  
I have a problem with Logstash, I want to start it on startup. It seems it works as a service but it can not work essentially. When I run `/usr/share/logstash/bin/logstash -f /etc/logstash/conf.d --path.settings /etc/logstash`, it works perfectly but I want to work it as a service. I changed _/etc/systemd/system/logstash.service_ file _ExecStart_ part `/usr/share/logstash/bin/logstash "-f /etc/logstash/conf.d" "--path.settings" "/etc/logstash"`. I tried all solutions that have similar topic with mine. So, is there any idea about why Logstash does not work as a service at startup?

P.S. : When I look logs with `journalctl --unit logstash`, it shows that  
No config files found in path {:path=\>/ /etc/logstash/logstash.conf"}  
No configuration found in the configured sources.

---

<div class="post-metadata">

**Author:** ![DavidKriv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidkriv/32/55658_2.png) [@DavidKriv](https://discuss.elastic.co/u/DavidKriv)\
**Post date:** [October 10, 2019, 2:15am UTC](https://discuss.elastic.co/t/logstash-service-starts-but-it-could-not-work-without-manually-starting-with-path-settings-and-f-parameters/200981/2 "2019-10-10T02:15:10Z")

</div>

Hi,  
I am also having trouble getting Logstash to startup as a Service. NSSM installs the service under Windows, but, the service will not start.

PS C:\Windows\system32\> Start-Service -Name "Elasticsearch Logstash 7.3.2"  
Start-Service : Failed to start service 'Elasticsearch Logstash 7.3.2 (Elasticsearch Logstash 7.3.2)'.  
At line:1 char:1

- Start-Service -Name "Elasticsearch Logstash 7.3.2"
- 

```auto
  + CategoryInfo : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
 ServiceCommandException
  + FullyQualifiedErrorId : StartServiceFailed,Microsoft.PowerShell.Commands.StartServiceCommand

```

Does anyone have any idea why this is happening ??  
Cheers,  
David

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 7, 2019, 2:15am UTC](https://discuss.elastic.co/t/logstash-service-starts-but-it-could-not-work-without-manually-starting-with-path-settings-and-f-parameters/200981/3 "2019-11-07T02:15:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
